New sc-download setup can't access files even with full permissions


#1

Sonarr version (exact version): 2.0.0.5153
Mono version (if Sonarr is not running on Windows): 5.8.0.108
OS: Synology DSM 6.1.5-15254

Description of issue:

Since the change to the users to use sc-nzbdrone and sc-download I can’t get Sonarr to post process files at all.

I tried setting log level to debug, but it didn’t add any extra info to this issue, so I change it back to Info and restarted again.

18-3-2 18:09:18.7|Warn|ImportApprovedEpisodes|Couldn’t import episode /volume1/Downloads/GetNZB/completed/TV SHow S01E01.720p.HDTV.x264-AVS/3b34d0dc103148e3ae740d270ceced79.mkv
[v2.0.0.5153] System.UnauthorizedAccessException: Access to the path is denied.

I have given Read/Write access to sc-download to /volume1/Downloads and I have even set the permissions to everything from /volume1/Downloads/GetNZB/ downwards to rwxrwxrwx. Nothing changes this. The new user group setup has all the permissions it needs to do anything, and if I manually add another to that group it can access files, just Sonarr wont.

There is no os reasons for the user to not have access, and looking up the error this is often considered to be something weird with WIndows, so I am assuming this is a Mono issue, but either way; it means that Sonarr is completely borked on Synology at the moment because the user permissions don’t work.


Permissions Messed Up After Upgrade on Synology
Recent Update - Synology causing Import Failures - Permissions Problem
Sonarr doesnt move downloaded episodes
Sonarr don´t Import Series in Folder after UPDATED - Synology 1513+
Synology: Missing root folder after latest update
Synology Download Station issue
#2

I had a couple of permission issues as well after the update, but they weren’t file related though. NZBGet already utlizes sc-download, so downloaded files are sure to have the right permission.

Issues I had were enough to warrant a reinstall, as some processes were failing do to the ownership changes, like SQL failures, log deletion, upgrades, etc…

I basically just did a backup, uninstalled the package, deleted some old folders (like /tmp/nzbdrone_upgrade or something or other) reinstalled the package, and restored the backup.
All permission issues were resolved.

So that might worth a shot.

See the wiki for backup/restore procedures on synology.


#3

Version 2.0.0.5153
Mono Version 5.8.0.108
DSM DSM 6.1.5-15254 Update 1

Same problem here, no post-download processing. I use Transmission for download.
If I try to edit a TV series, I cannot browse the Video folder, so it’s a permission problem.

Owner: admin
Group: sc-downloads

Also, restart of Sonarr does not work. I must restart the NAS to work.

I suspect is a Mono problem.


#4

Same issue here!
Please fix this asap


#5

It’s either source or destination permissions problems (debug logs will show both paths). The nzbdrone user should be a user of the sc-media` group (though not visible in the UI) and that group will need read and write access.


#6

If we don’t see the nzbdrone use in the UI, how can we check or add this user?

debug logs are not very useful

Blockquote
18-3-3 10:40:02.8|Error|DownloadedEpisodesImportService|Import failed, path does not exist or is not accessible by Sonarr: /volume1/Video/sonarr-tv/Arrow.S06E14.720p.HDTV.x264-AVS

.


#7

all permissions are checked and OK the problem is with Mono
please fix this asap, missing all my shows… :smiley:


#8

Check Sonarr update in Synology - new version noew.
It fixes the problems


#9

it did not fix it for me…
Stil get the “Access to the path is denied.” error


#10

Not fixed for me either…


#11

I managed to get mine working again. Along with admin:sc-download permissions on the video folders, I also had to chmod the video folders to 777

Everything working again for me now.


#12

chmod 777 on the dl folder does resolve this issue.


#13

Hi, what exactly did you do as I am having the same problems.

Thanks


#15

Still not fixed even with chmod 777


#16

I’m also having the same issue, I’ve not tried a CHMOD but I’ve tried setting the group permissions and even going in to the shared folder ans setting sc-nzbdrone users full permissions but nothing


#17

Same here. But on my Synology it’s the “Season xx” folder that has problems. All series named folders are correct, but the Season folder has a owner “101” and a group “users” with drwxr-xr-x. So I understand why it can’t put files there.
But why this has changed? Don’t know. I’ve seen it before when Sonarr tries to create new Season folders that the series folder changed in something equally odd (drwxr-xr-x).


#18

Connecting via Telnet and running CHMOD 777 -R fixed my issue


#19

This did not fix the problem. Still ‘access denied’.


#21

Same here as well. Seems everything went bonkers with my installation. Very nice…

Import failed, path does not exist or is not accessible by Sonarr

This happened after updating Sonarr and Mono on Synology.
Tried everything suggested in this thread, but nothing works. Als restart of Sonarr doesn’t work (as someone else described). Only way to get Sonarr to start again is by rebooting the Synology completely.

Hopefully this will be resolved asap. TY.


#22

You are asking that in the wrong forum. The devs have nothing to do with the synocommunity. They kinda screwed the pooch for upgrades when they altered the user nzbdrone instead of just adding that user to the sc-download group like they did with deluge.

Sometime the best thing to do is to start “fresh”.

For instance, instead of trying to tweak folders packages and myself fiddling in the *nix layer have been messing with in the past, I just created a new shared folder for my download clients, gave sc-download permissions in the Syno layer, and stayed away from the *nix layer. Seems to work like a charm.

As far as restarting, updating, etc. just make a backup (see wiki for syno instructions), deinstall Sonarr package, reinstall the package, and restore the backup. That will mitigate any permission errors in the installation folders and databases.