Another, path does not exist or is not accessible by Sonarr

**Sonarr version
**Mono version < listed in Sonarr. Actual downgraded version installed is
**OS Asustor ADM 3.4.7.RFO2
Debug logs:
Description of issue:

Since updating to Sonarr (Initial release with Docker) episodes are not being moved nor renamed.

When adding a new series, Sonarr successfully creates a series folder at /volume1/Download/Completed_Shows/ with permissions pref set RWD (file chmod mask - 0777 and folder chmod mask - 0777).

Sonarr and NZBGet are running on the same NAS (Asustor AS5002T) so Drone Factory Options are not set (Interval 0).

Downloaded episodes are incorrectly being added to:


Instead of the intended location of:


The result after adding a new series:

/volume1/Download/Completed_Shows/Breeders S01E01 REPACK 1080p HEVC x265-MeGusta/

I have downgraded Mono to version based on the recommendation in the changelog.

Despite the port number set at Settings > General > Port Number being 8989, the actual port number in the URL is

Whilst the permissions of the newly created series folder are correctly set as RW (0777) for all. The newly downloaded episode folder differs with RW - Owner, and RO - Group / Others.

If I get permissions on the actual media file (.mkv) they are listed as ‘Special Permissions’.

Settings > Download Client > NZBGet > Host = Using ‘localhost’ instead results in:

'Test was aborted due to an error: Unable to connect to NzbGet. Error: ConnectFailure (Connection refused): ‘http://localhost:6789/jsonrpc’ ’

Any advice as to where to look next would be greatly appreciated.

Not sure about the actual error, but:

  • You’re using the same location as download path (to be used by your download client to drop files and sonarr to pick them up) and sorted series (managed by sonarr). Don’t do that, it causes all sorts of issues.
  • I don’t know where the advice is coming from to downgrade, but 5.8 is quite old. I don’t think sonarr even supports that anymore.

Hi Thirrian
Thanks for taking the time.

Prior to upgrading, the NZBGet download path and Sonarr path were the same and working correctly for many years.

However, I tested that theory and changed NZBGet’s destination folder, it made no difference to the outcome of the problem.

Advice regards to Mono came from the apps changelog (attached).

Asustor user here, you don’t need mono installed separately, it’s included in the Docker image (hence Sonarr showing a different version). I’d recommend removing it.

What volumes have been added for your Sonarr Docker container?
If you aren’t already, and would like to, use Portainer for a webUI for Docker.

Thanks IL2BT
Mono uninstalled
Portainer installed

Local Portainer Volume lists only 1 - /volume1/.@plugins/AppCen[…]umes/portainer_data/_data

Sorry, the volumes for Sonarr, not Portainer

I’m not clear what you mean. The directory Sonarr is pointing to is:


If you are asking for volume info from inside Portainer you’ll need to direct me.

From that screenshot, click local, then Containers, Sonarr, and scroll down to Volumes.

Ok, so if you scroll back up to the top of that page, click the button Duplicate/Edit, then scroll down to Advanced container settings and click the Volumes tab.

I wouldn’t have thought it would have made a difference, but try changing:

Then click the Deploy the container button just above that, and then Replace. Wait for it finish and then try Sonarr again.

In Sonarr, if you go to Settings and show advanced settings, can you screenshot the Media Management tab? Then under the Download Client tab, do you have anything set under Remote Path Mappings?

Great instructions… thank you!

Sadly, it didn’t change the outcome. The error remains:
“Import failed, path does not exist or is not accessible by Sonarr: /volume1/Download/Completed_Shows/Breeders.S01E01.REPACK.1080p.HEVC.x265-MeGusta”

One thing did change tho. Adding a new series failed to create an empty folder despite the preference being set.

Remote Path Mappings

So I restored the original directory of /volume1/Download in Volumes and retried adding the new series again, the new series folder was created this time.

Permissions are kinda outside of my knowledge base, but on mine I’ve just left it defaulted to No, without any apparent issues. Could you try disabling it to see if that makes a difference?

Is there a reason you have it enabled? I will smile and nod and pretend to understand :stuck_out_tongue:

I switched off Permissions and performed the same test. Same outcome.

My rational was that if Sonarr didn’t have permissions to create, move and rename episodes then that might be the root cause. I guess I just wanted to rule this out.

Are you aware of where the scripts that handle ‘Completed Download Handling’ reside or controlled?

Perhaps I should try and create a new directory, say:


Then leave: volume1/downloads/completed_shows as the destination for NZBGet.

In case theres something funny going on with /completed_shows

The first paragraph is just questions, not requests for you to do anything. As I said, permissions are not something I have any great knowledge of.

Did you try adding 0777 to chown User and Group? Also, in ADM > Access Control > Local Groups, Administrators is listed as 999 for me. Is it 777 for you? If not, have you tried using that?

Completed Download Handling in Sonarr can be found in Settings > Download Client

Yea, a new folder is worth a try, though as you said it was working previously, so that’s a bit strange.

You could also try a new share, setting it up in ADM > Access Control > Shared Folders, and then adding a new one, or using one other than Downloads, e.g. I’ve used Media as you can see in my screenshot.

Generally you tend to want where you’re downloading, and where you’re storing, to be on the same share, so that files are moved, rather than copied and then deleted. So my setup is:

|— /Complete
|— /Films
|— /Incomplete
|— /TV

/Media being the share, with Transmission downloading into /Incomplete, then moves files to /Complete once finished, and then Sonarr and Radarr detect this and move files to their appropriate folders.

I did not.

Its the same at 999

There don’t appear to be any further controls over ‘Completed Download Handling’ other than an On/Off switch. I wondered if there was any further controls.

I created a new folder for sonarr to monitor:


NZBGet is moving completed episodes into:


Restarted both Sonarr and NZBGet, and cleared Sonarr’s logs

Added a new series.

The new series folder was not created inside ‘tv’ per the preferences.

Episodes all downloaded successfully into:


It appears ‘Completed Download Handling’ is not functioning and the sonarr logs show:

Import failed, path does not exist or is not accessible by Sonarr: /volume1/Download/NZBGet/complete/tales.from.the.loop.s01e01.1080p.web.h264-insidious

Curiously, when I set ‘volume1/Downloads/Completed_Shows’ as Sonarr’s folder to monitor and NZBGet’s completed download location the new series folder IS created.

Sadly however, the episodes are left, unmoved, and unnamed in ‘volume1/Downloads/Completed_Shows’

0777 being the your current user account then I take it?

So seemingly NZBGet can access the share fine, but Sonarr can’t.

My only suggestion would be disabling Set Permissions in Sonarr, stop Sonarr in Portainer, add or identify a new share you want to use, add this in Portainer (and keep /volume1/Download), and deploy it. Then try again in Sonarr.

Unfortunately, short of some major revelation coming from this, I’m out of ideas (beyond ‘backup your settings and start from scratch’). :crossed_fingers:

Set Permissions - OFF

Stopped Sonarr in Portainer and added /Media/TV

Kicked off another new show. Same result. Missing empty series folder, and NZBGet successfully downloads and unpacks to: volume1/Downloads/NZBGet/complete

Looking at the logs in Portainer I see:

If I delete Sonarr from App Central, can I clear or delete Docker so as to start afresh?

BTW: I’m using Docker-ce ver. 19.03.8.r3

Try changing NZBGet to volume1/Media/NZBGet/complete (and /incomplete I’m guessing), as that seems to be where the issue still lies.

If the above doesn’t change anything, then in Sonarr go to System > Backup, click the Backup button, and once a new backup appears, click it to download.

You can uninstall Sonarr from App Central, and double check Portainer to make sure only Portainer shows in Containers, Images, and Volumes (if not, select and remove Sonarr). Then in ADM’s File Explorer open the Docker share and delete the Sonarr folder.

At that point you’re ready to start from scratch. If you want to be really thorough you can uninstall Portainer and Docker too, restart the NAS, and reinstall everything.

Try without restoring your Sonarr backup first. If that works, backup those settings and download them, restore your old settings and try again. If everything works fine, great. If not, restore the working settings, and start customising things to how you like, periodically testing to see if something specific was causing the issue.

Followed your instructions to the letter.

Reinstalled Sonarr and added ‘Indexers’ and ‘Download client’ config only (no other preferences were set).

Added a new series and immediately got the error:
Import failed, path does not exist or is not accessible by Sonarr: /volume1/Download/NZBGet/complete/friday.night.dinner.s06e01.1080p.hdtv.x264-failed

NZBGet worked correctly. Both Sonarr and NZBGet are using folders in the same volume (Sonarr - volume1/Download/Completed_Shows and NZBGet - volume1/Download/NZBGet/complete).

Portainer looks correct, with Sonarr container and volumes setup.

These are the version numbers

Sonarr -
Docker-ce - 19.03.8.r3
Portainer - 1.23.1.r1
NZBGet - 20180620

I’ve tried using ‘volume1/media’ and ‘volume1/download’.

The only other thing I can think of is that trying to use a native app with a Dockerised app is causing an issue. That’s what the volume mapping tries to work around.

Uninstall NZBGet (or maybe just disable in App Central for now) and install it using Portainer instead -

If you need specific instructions of how to do so, let me know (I know that working it out the first time was a pain for me).

Promise this is my last stab at this, I’m out of ideas now.