Wrong series titles used with no results from indexer (Grey's Anatomy and Chicago P.D.)

Sonarr version (exact version):
OS: Windows 10 Pro
Debug logs: -
Description of issue:
About three weeks ago this issue have started, Sonarr can no longer download mentioned series, until I manually edit the database and remove or fix the alternative titles.

Let’s check the first serie, Grey’s Anatomy. It has two alternative titles listed in Sonarr:

  • Anatomia de Grey
  • Greys Anatomy Die jungen Aerzte

If we check the official source: https://www.thetvdb.com/series/greys-anatomy those two titles are not mentioned, so I am assuming they are coming from the mapping service https://thexem.info/
The interesting thing is that it worked up until about three weeks ago, so something has changed. When I’m checking the debug logs, I see these titles being used for querying the indexer:

  • &q=Anatomia%20de%20Grey
  • &q=Greys%20Anatomy%20Die%20jungen%20Aerzte
  • &q=Grey%27s%20Anatomy

So, it searches for both alternative titles and the original title. But because the scene does not use apostrophes in releases, it can’t find anything. Not even sure how the apostrophe was added in the query, thought that the sonarr cleans those before query is being made.
I also searched the xem’s request document and found this entry:
2/3/2019 4:50:53 73762 | Greys Anatomy | Grey’s Anatomy | Same title to Sonarr
Well, it’s not in my case it’s not.

When I open the sonarr.db and fix the titles (remove one alternative and change the second one into “greys anatomy”), it again works. Until the data is refreshed …

Second serie, Chicago P.D… It has two aliases listed on TVDb:

  • Chicago Police Department
  • Chicago PD

Debug logs shows these titles being used:

  • &q=Chicago%20Police%20Department
  • &q=Chicago%20P%20D

Clearly, both are wrong and never finds anything. It should be using &q=Chicago%20PD. This one was also working not long ago, but now failing. When I do change the local .db to “chicago pd”, the downloads start working.
xem’s request form:
7/23/2019 9:22:29 269641 | Chicago P D | Chicago P.D. | Sonarr searches for “Chicago PD” but not for “Chicago P D”. | Added
In my case, it has 0 results when searching for “chicago p d” and it does not search for “chicago pd”.

I see that in both cases, the issue would be solved if it would use the original, English serie’s title, of course filtered for searching on public trackers.

So, how do I fix this mess? Altering the local .db is beginning to be a problem, since it feels like I’m fixing it regularly.
I assume I mist have missed something basic, a tick somewhere and this would start working. But as said, didn’t change anything and it worked …

What trackers are you using? If their indexers support raw search, then that would be why an apostrophe is now being used. However, the last indexers to have it enabled that I’ve seen were from December last year, so I don’t know why your issue would have only arisen 3 weeks ago.

Neither do I. I wasn’t even aware of this great software until about two months ago, so that’s the time I installed it (approx). And it worked from the start but then started failing.

Indexer is Torznab, which connects to Jackett, which has 1337x configured as indexer. I assume that Torznab or 1337x do support raw search and that’s why this is happening. Sorry for not providing this info earlier.

So the question is how to prevent it. Or how to configure Sonarr to use only English/original serie title while ignoring alternatives, and with cleaned title (aka. removing all special characters and dots).

Yea, 1337x supports raw search - Jackett/src/Jackett.Common/Definitions/1337x.yml at 4f14e4766f61a7ab9e26c69793bd4a76b905e3e8 · Jackett/Jackett · GitHub

Saw the same issue before:

I’m not sure either person followed that up, but you’d need to ask about it on Discord, as I’m not sure if this is intentional or a bug. Either way, let me know.

Thank you for your response, but I’m not sure if this is Jackett’s issue, I still think it’s Sonarr’s.

This is what I did today. After you pointed out the definition file, I disabled the updating of Jackett and changed the allowrawsearch to false. Restarted both services, deleted current Torznab indexer and re-created it. After that I checked Sonarr and Jackett logs.

2024-05-19 08:58:11.6|Debug|Torznab|Downloading Feed,100041,100042,100070,100071&extended=1&apikey=(removed)&offset=0&limit=100&q=Chicago%20P%20D&season=11&ep=12
2024-05-19 08:58:18.5|Debug|Torznab|Downloading Feed,100041,100042,100070,100071&extended=1&apikey=(removed)&offset=0&limit=100&q=Chicago%20Police%20Department&season=11&ep=12

  • Chicago P D
  • Chicago Police Department

2024-05-19 08:55:08.8276 Info Torznab search in 1337x for Chicago P D S11E12 => Found 0 releases [6912ms]
2024-05-19 08:55:17.8249 Info Torznab search in 1337x for Chicago Police Department S11E12 => Found 0 releases [8988ms]

As you can see, Jackett searches for what’s provided, in this case both wrong serie name. So the issue must be with Sonarr. I’m also a bit puzzled why Sonarr only searches in alternative serie name and not in the original name.

Any ideas you can share?

Sorry, when I said ask about it on Discord, I meant the Sonarr Discord, as mentioned in Sonarr searching for different keywords across indexers. I’m saying the issue lies with Sonarr.

Thank you for your response. I don’t use Discord, so will ask elsewhere. Somehow expected that since this is an official forum, that developers might monitor it, so that I won’t need to create an issue on GitHub.

They do, but Discord is a lot faster. If you’re happy to wait, I’m sure @markus101 will reply when they’re free.

I don’t mind the speed, just that it will be resolved. I do understand that people have their own personal lives and other tasks that are more important, so I do not expect everybody to drop everything to respond to my inquiry.

Starts to feel like a shill for another account with a weird name. Same hostility, same expressions…

Indeed it does, fixed the glitch…


You don’t edit the DB you need to request a mapping on the form you’re referencing and provide additional details, a lot has changed in the nearly 4 years since those requests, but I’ve added them both now.

Same issue with Mike Judge's Beavis and Butt-Head and 90 Day Fiancé (or was at one point, I haven’t rechecked since then, and am not really free now).

Should raw search be reworked in general, so as to search for both the raw and sanitised titles? I’m sure there will be many other examples where a tracker will support punctuation and diacritics, and some results may even be returned, but many others won’t.

We’ve disabled it for a few indexers in Jackett and Prowlarr, because it caused issues for some users, but I’m sure it being disabled then causes other problems which aren’t reported.

That was also my plan, to request a mapping but before I did that, I actually did search if mappings have already been added. Maybe I didn’t express well enough, but mappings were already there or a comment was added that the title “Grey’s Anatomy” is the same for Sonarr as “Greys Anatomy”, so I didn’t proceed by requesting those.
So if I understand you correctly, you have added mappings to the xem and it will be synced with my Sonarr? I checked and see that Chicago PD will be released tomorrow and Grey’s Anatomy in two days. After those are in the wild, I will report back if adding the mapping solved the issue.

And I thank you for removing that nagging user! Those can truly be found at every forum there are out there …

The best solution would be to allow manually adding or removing the alternative titles or even editing the original title, to tell the indexer what to search for exactly. Could be hidden under advanced settings, since not all users are computer versed and it will cause problems for some.
But did read in one of the GitHub tickets that this won’t be supported, was kind of hoping it would be. Then we could simply alter the title as we see fit and not add a numerous records into xem service.

The whole point of the xem replacements is that only one person has to request a change and then everyone benefits, no need for manual edits.

If you instead allow manual edits, many if not most of these would no longer be reported, and then everyone is just making manual edits.

I understand the idea behind it, but even you reported two series that are not picked up properly. So I would leave both: xem service and manual edit, for stubborn series. And then let the user decide on how to proceed. Since I do not see beneficial that right now my set up makes three queries (for Grey’s Anatomy) and is not returning any results, while manual edit would make one search. I assume that with added additional xem entry, now it will make four searches total.

Will report back in few days if updated xem service solved my issue or not.

People generally prefer the path of least resistance; if it’s less work and quicker to change it on their own system, they likely won’t search the wiki for a form and then wait a few days or longer.

I didn’t report the other series, I suggested those users should discuss the issue on Discord, and I’m not sure they did. I also don’t think the sanitised titles should be part of the xem alt list.

Take for example Grey’s Anatomy. Currently an indexer with raw search uses Grey's Anatomy and one without uses Greys Anatomy. However, if the sanitised title is added as an alt, then an indexer with raw search will use Grey's Anatomy and Greys Anatomy, whereas one without will use Greys Anatomy twice.

I do know that people will use the most easy path, so if you want to use the xem service, maybe add a support for it right into Sonarr? Since as you saw, when you mentioned Discord, even I was against it since I don’t have an account there and was not willing to create one just for this. After searching the xem service, the “Greys Anatomy” was claimed that it was already supported by Sonarr which I also assumed. That it cleans the title and sends it to the indexer.

But anyway. I can report that both series started to work! I appreciate the response and quick solution!

Not sure how it goes on this forum, but this topic can be closed.

There’s a link to the wiki in Sonarr, under the System > Status > More Info section. Linking to subsections of the wiki in Sonarr, when a popular issue arises, gets messy very quickly.