Sonarr fails to start on Synology after latest package update

Sonarr version 20200409-16:
Mono version 5.20.1.34-13:
OS - Synology DSM 6.2.2 update 4:
Debug logs:
**Sonar ran fine for years, latest update on synology and now i get a “failed to run package”
tried restarting synology
uninstalling Sonarr & then mono & restarting synology, reinstalling again, same issue “failed to run package”

I then uninstalled again and manually installed the previous versions of both Mono 5.18.0.240-12 & Sonar 20190320-15 from https://synocommunity.com/package/mono

same issues “failed to run package” - note that in all cases - Mono says “started” but Sonarr wont start.

ive winscp’d to /volume1/@appstore/nzbdrone/var and the log shows the below

Sun Apr 12 18:33:13 IST 2020
Starting nzbdrone command env PATH=/volume1/@appstore/nzbdrone/…/mono/bin:/volume1/@appstore/nzbdrone/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/syno/sbin:/usr/syno/bin:/usr/local/sbin:/usr/local/bin HOME=/volume1/@appstore/nzbdrone/var LD_LIBRARY_PATH=/volume1/@appstore/nzbdrone/lib /volume1/@appstore/nzbdrone/…/mono/bin/mono /volume1/@appstore/nzbdrone/share/NzbDrone/NzbDrone.exe
r4_conv_to_r8 R47 <- R44

  • Assertion: should not be reached at decompose.c:1891

=================================================================
Native Crash Reporting

Got a SIGABRT while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries
used by your application.

/proc/self/maps:
00010000-00369000 r-xp 00000000 fd:00 2067 /volume1/@appstore/mono/bin/mono-sgen
00378000-0037f000 rwxp 00358000 fd:00 2067 /volume1/@appstore/mono/bin/mono-sgen
0037f000-004db000 rwxp 00000000 00:00 0 [heap]
40000000-40020000 r-xp 00000000 09:00 16807 /usr/lib/ld-2.15.so
40020000-40023000 rwxp 00000000 00:00 0
40023000-40024000 r-xp 00000000 00:00 0
40024000-40025000 —p 00000000 00:00 0
40025000-40026000 rwxs 00000000 00:10 344895 /dev/shm/mono.1188
40026000-4002f000 rwxp 00000000 00:00 0
4002f000-40030000 r-xp 0001f000 09:00 16807 /usr/lib/ld-2.15.so
40030000-40031000 rwxp 00020000 09:00 16807 /usr/lib/ld-2.15.so
40031000-400c9000 r-xp 00000000 09:00 16846 /usr/lib/libm-2.15.so
400c9000-400d8000 —p 00098000 09:00 16846 /usr/lib/libm-2.15.so
400d8000-400d9000 r-xp 00097000 09:00 16846 /usr/lib/libm-2.15.so
400d9000-400da000 rwxp 00098000 09:00 16846 /usr/lib/libm-2.15.so
400da000-400e0000 r-xp 00000000 09:00 18141 /usr/lib/librt-2.15.so
400e0000-400ef000 —p 00006000 09:00 18141 /usr/lib/librt-2.15.so
400ef000-400f0000 r-xp 00005000 09:00 18141 /usr/lib/librt-2.15.so
400f0000-400f1000 rwxp 00006000 09:00 18141 /usr/lib/librt-2.15.so
400f1000-400f5000 r-xp 00000000 09:00 18121 /usr/lib/libdl-2.15.so
400f5000-40104000 —p 00004000 09:00 18121 /usr/lib/libdl-2.15.so
40104000-40105000 r-xp 00003000 09:00 18121 /usr/lib/libdl-2.15.so
40105000-40106000 rwxp 00004000 09:00 18121 /usr/lib/libdl-2.15.so
40106000-4011b000 r-xp 00000000 09:00 18619 /usr/lib/libpthread-2.15.so
4011b000-4012b000 —p 00015000 09:00 18619 /usr/lib/libpthread-2.15.so

=================================================================
Basic Fault Adddress Reporting

Memory around native instruction pointer (0x40177fa0):0x40177f90 03 10 a0 e1 04 20 a0 e1 43 7f a0 e3 00 00 00 ef … …C…
0x40177fa0 01 0a 70 e3 08 00 00 8a 90 40 bd e8 1e ff 2f e1 …p…@…/.
0x40177fb0 00 00 50 e3 f5 ff ff ca 02 21 c0 e3 00 00 52 e3 …P…!..R.
0x40177fc0 00 00 60 12 03 00 a0 01 f0 ff ff ea 00 10 60 e2 …............

=================================================================
Native stacktrace:

0xf2164 - /volume1/@appstore/nzbdrone/../mono/bin/mono : (null)
0xb39d4 - /volume1/@appstore/nzbdrone/../mono/bin/mono : (null)
0x40179370 - /lib/libc.so.6 : __default_rt_sa_restorer_v2
0x40177fa0 - /lib/libc.so.6 : gsignal
0x4017bea8 - /lib/libc.so.6 : abort
0x298cd0 - /volume1/@appstore/nzbdrone/../mono/bin/mono : monoeg_assert_abort
0x2828e8 - /volume1/@appstore/nzbdrone/../mono/bin/mono : (null)
0x27d350 - /volume1/@appstore/nzbdrone/../mono/bin/mono : (null)
0x298c78 - /volume1/@appstore/nzbdrone/../mono/bin/mono : (null)
0x298f14 - /volume1/@appstore/nzbdrone/../mono/bin/mono : monoeg_assertion_message
0x7ddc4 - /volume1/@appstore/nzbdrone/../mono/bin/mono : (null)
0xf8988 - /volume1/@appstore/nzbdrone/../mono/bin/mono : (null)
0xf9218 - /volume1/@appstore/nzbdrone/../mono/bin/mono : (null)
0x38ffc - /volume1/@appstore/nzbdrone/../mono/bin/mono : (null)
0xb7184 - /volume1/@appstore/nzbdrone/../mono/bin/mono : (null)
0xb7810 - /volume1/@appstore/nzbdrone/../mono/bin/mono : (null)

=================================================================
Telemetry Dumper:

Pkilling 0x41d49450 from 0x400217c0
Entering thread summarizer pause from 0x400217c0
Finished thread summarizer pause from 0x400217c0.

Waiting for dumping threads to resume

Debug info from gdb:

=================================================================
External Debugger Dump:

mono_gdb_render_native_backtraces not supported on this platform, unable to find gdb or lldb

=================================================================
Managed Stacktrace:

  at <unknown> <0xffffffff>
  at System.Collections.Hashtable:.ctor <0x0002b>
  at System.Configuration.Configuration:.ctor <0x0002f>
  at System.Configuration.InternalConfigurationFactory:Create <0x00073>
  at System.Configuration.ConfigurationManager:OpenExeConfigurationInternal <0x0037f>
  at System.Configuration.ClientConfigurationSystem:get_Configuration <0x00043>
  at System.Configuration.ClientConfigurationSystem:System.Configuration.Internal.IInternalConfigSystem.GetSection <0x00017>
  at System.Configuration.ConfigurationManager:GetSection <0x00047>
  at System.Configuration.ConfigurationManager:get_AppSettings <0x0001b>
  at NLog.Common.InternalLogger:GetAppSettings <0x00013>
  at NLog.Common.InternalLogger:GetSettingString <0x0002b>
  at NLog.Common.InternalLogger:GetSetting <0x0002b>
  at NLog.Common.InternalLogger:Reset <0x0002b>
  at NLog.Common.InternalLogger:.cctor <0x00033>
  at System.Object:runtime_invoke_void <0x00073>
  at <unknown> <0xffffffff>
  at NLog.Config.LoggingConfiguration:Dump <0x00053>
  at NLog.LogFactory:set_Configuration <0x001b7>
  at NLog.LogManager:set_Configuration <0x0002f>
  at NzbDrone.Common.Instrumentation.NzbDroneLogger:.cctor <0x0002b>
  at System.Object:runtime_invoke_void <0x00073>
  at <unknown> <0xffffffff>
  at NzbDrone.Console.ConsoleApp:.cctor <0x00017>
  at System.Object:runtime_invoke_void <0x00073>

=================================================================

**:

I have exactly the same problem, since yesterday.
I updated to the newest version, but from that time i can’t start the Sonarr service.

I uninstall Mono / Sonarr en re-install both packages without any succes :frowning: The services didn’t came up.

Who can help us with solving this problem?

Yeh and I have tried manually going back to the previous versions and still get the same error.
Hope someone can shed some light!

Thanks

Exactly! I also tried to install previous packages, even from 1 year old. I think its because latest DSM update?

I hope this problem is resolved soon! :slight_smile:

I didn’t think my DSM had updated…
Sonarr was working fine this morning and the only changes made were updating mono & sonarr through the Synology application page.
My DSM version hasn’t updated today

I was able to get my instance running again by downversioning both Mono and Sonarr two versions.

Not ideal but it gets past the error.

Synology DS212j: DSM 6.2.2-24922

Mono: Version 5.8.0.108-11 https://synocommunity.com/package/mono

Sonarr: 20180303-13 https://synocommunity.com/package/nzbdrone

I ended up installing sonarr on an old nuc I n longer use running windows and restored the sonarr dB from the Synology and fixing paths…
Then upgraded to the latest beta… Not ideall, would rather have it all on the Synology… but at least with windows it’s much easier to backup/restore/manage/diagnose issues as the support from sonnar was non existent.

Sounds like issues with ARM-based synology devices due to an issue with mono on arm: https://github.com/mono/mono/issues/12537

There are some links at the bottom to synology community as they try to work around it. Hopefully the mono package is updated to resolve the issue soon.

Ah cheers Markus! Think I’m actually happier with server 2019… Might even move my sabnzb over one day to lighten the load on the Synology.
V3 beta is running really really well so far…
Cheers

How did you obtain an older version? The links you provided don’t appear to lead to anywhere that contains an older version of either package.

When I hit those links a couple of months ago they had download links with previous versions available :confused: Not sure where they went or why they were taken down.

Mine’s working now, but TBH if it goes down again I might just buy a raspberry pi and move all my downloading utilities onto it. It’s getting harder and harder to keep my old NAS funtional.

My Synology DS413j (DSM 6.2.3-25426) been experiencing this issue for the last three weeks. I have uninstalled and reinstalled Mono and Sonarr v20200409-16 repeatedly but continue to get the same error, “Failed to run the package service.”

Is this an issue that is being actively worked on? Or should I switch to a different product? Are there logs I can gather that might help troubleshoot the root cause?

note - this version (and all of them before it) runs perfectly fine in docker on a syno nas

Package Version: 3.0.3.849-ls14 by linuxserver.io
Mono Version: 5.20.1.34

i would expect v2 from there to work just as well

so you always have the option of shifting to docker - which also removes practically all mono issues, and any chance of those issues taking out dsm as well

Thanks but that’s not an option for me as docker is not supported on the DS413j.

Same issue here. Old DS212J worked flawlessly for years, now the service wont start.

Time for a new NAS if this isn’t actually being worked on.

Well, I was able to get it working with the help of u/feroc on Reddit. It’s basically just what he mentioned in (https://www.reddit.com/r/sonarr/comments/4c7ddp/howto_sonarr_on_synology_dsm_60_workaround/) except the path was slightly different since newer versions have come out since that post was made.

After installing the beta version of Mono (note the change in capitalization from the original “mono”), the MONO_PATH line in service-setup (not start-stop-status as mentioned in the original post) needs to be edited to read: MONO_PATH="/var/packages/Mono/target/usr/local/bin"

After I did that, I tried starting Sonarr and got the same “Failed to run the package service.” BUT… when I tried it again a couple minutes later I got no error message and in fact it started successfully!

As a complete newbie to the whole SSH and changing stuff can I please confirm that what you mean is, instead of going to the “start-stop status” to change the input, I need to go to the “service-setup” and change the line? Thanks

Yes, that is what I did and that fixed it.

1 Like

Hi.
The beta version has been removed and I cant get Sonarr to start (been weeks since it worked), do you have the install file available for the 413j or know where to get it?

thanks

Mono beta is here if anyone else is having the issue: https://archive.synology.com/download/Package/spk/Mono/4.6.2-0096/Mono-armv5-4.6.2-0096.spk