Sonarr not launching after DSM update

Sonarr version: 20200921-18
Mono version: 5.20.1.37-17 & Mono Beta: 4.6.2-0096
OS: Synology DS212 - DSM 6.2.3-25426
Description of issue: Sonarr not launching after DSM update

Hi all,
Hope you will be able to help me out with this and I apologies upfront for being a rookie on this subject.
Since a couple of years i’m using Sonarr (& Radarr) on my DS211, both auto feed NZB’s to NZBget.

Since early JAN I was receiving the error from windows explorer when trying to access the NAS;
“Multiple connections to a server or shared resource by the same user, using more than one user name, are not allowed. Disconnect all previous connections to the server or shared resource and try again”
Google didn’t provide me the answer on why I all of sudden had multiple connections.
Eventually I opened Synology DSM and - hindsight looking - made the mistake to update everything (thus DSM but also the packages), this in an attempt to get rid of the windows error.
Now receiving the error “failed to run package service” when i tried to launch Sonarr service through DSM package center.

Spend 4 hours re-educating myself ( + 4 hours hitting myself in my face) and found this info on this forum, Reddit & Github;




I believe this is where I am now;

  • Sonarr appears to require Mono because I now have DSM 6.0+;
  • Mono doesn’t seem to be working well on DS212?;
  • Workaround available to install Mono Beta - which i did (version “Mono-armv5-4.6.2-0096” for DS212 “88f6282 (armv5)”);
  • SSH in DSM activated and through FTP (winSCP) i’m able to access the NAS, this works and I also see the non shared files;
  • Sonarr “service-setup” has to be amended to divert it to Mono Beta;

This is where I get stuck, don’t have sufficient rights (through FTP) to write/change/overwrite the files in those folders.
How do I fix this? I also tried PuTTY (?), but I have no clue what i’m doing there, so not sure if it will be a success if I use this.

Want to prevent I need to remove or reinstall Sonarr (due to the amount of work to re-configure all settings + series that I have “subscribed” to).
Don’t want to reinstall an old version of DSM neither nor remove all the files on the NAS.

If applicable how did you get around this, or what would be your suggestion to fix this?
Many thanks for the help! Cheers!

  1. Sonarr requires mono if you’re not running it on Windows
  2. The processor in that model has had a lot of issues, there might be some people running on it without issues, but when it has issues it tends to fail hard.

Back it up, you can do that without it running: Backup

You’ll have to look at Sonarr’s logs to see if it’s even being started and failing or there is an issue with mono preventing it from starting.

1 Like

Hi Markus, thanks for the quick reply.

Its seems the chipset is not fully compatible with regular mono, hence the Mono Beta workaround?
Sonarr has been working well for years on the older DSM’s versions (which didn’t require mono?), however I don’t see downgrading (if possible at all?) as a solution.

Despite, I think I’m pretty close to a solution as described in the first post, just need that last push in the right direction, by being able to edit those files or maybe somebody has another suggestion?

I tried backing up through your link, but the “.config” folder is nowhere to be found on any of those path’s, all other folders are there, but just not the “.config” folder - strange?

/usr/local/nzbdrone/".config" [ = missing]
/volume2/@appstore/nzbdrone/var/".config" [ = missing]

Also don’t want to spend another couple of hundred bucks on a new NAS either.

It definitely required mono, possibly a different version worked with that chipset.

Perhaps because it’s never run? Removing the package from synology may remove the config (I recall a discussion about that when the package was first made, but not 100% sure that’s still the case).

Probably easiest to copy those files to another location via SSH (and sudo), edit them there (where you have permissions) then replace them afterwards.

1 Like

Hi Markus, thanks again for your reply!

Perhaps because it’s never run? Removing the package from synology may remove the config (I recall a discussion about that when the package was first made, but not 100% sure that’s still the case).

Valid point, I’m beginning to doubt myself if I have not removed it by accident earlier…in an attempt to get it working somehow. So if there is a solution, without downgrading DSM but still to be able use Sonarr with NZBget, i’m more than happy to it. Then I just have to spend another evening reconfiguration everything, which seems required anyway now, although i’m not certain yet if I looked at all possible places for this map.

Probably easiest to copy those files to another location via SSH (and sudo), edit them there (where you have permissions) then replace them afterwards.

So this is where I get stuck; I downloaded the “service setup” file with winSCP to my desktop, amended the code with old fashion notepad from:

PATH="${SYNOPKG_PKGDEST}/bin:${PATH}"
MONO_PATH="/var/packages/mono/target/bin"
MONO="${MONO_PATH}/mono"

to:

PATH="${SYNOPKG_PKGDEST}/bin:${PATH}"
MONO_PATH="/var/packages/Mono/target/usr/local/bin"
MONO="${MONO_PATH}/Mono"

This so it’s referring to Mono Beta iso regular mono, which is the trick according to the shared posts earlier, basically this post summarizes my solution (at least I think).

But when uploading it, I get this error:
scp: /var/packages/nzbdrone/scripts/service-setup2: Permission denied
Neither am I able to upload a different named file in the same folder for same permission error.
For clarity also adding screenshot, any idea how I can get this fixed, or how I can get a new install of Sonarr working without downgrading DSM ?

I don’t know what Sudo is and how it works…is there an easy workaround?

image

You’re not going to get very far with linux if you don’t know what it is/how to use it. You either need to learn to use it or change the permissions of the files you need to edit, but both of these are something that I can’t help you with.

1 Like

I did the edit of the service-setup file with root access straight on the synology. No download or upload. You can use putty in windows to connect to the synology via ssh. Login using admin account. After that enter su -
Type your admin password. You have root access now (god mode) in linux. Browse to the folder using cd command. Then use vi editor to edit the file.

Change the small letters mono to Mono with capitol letter M. Save the file and you should be good to go.

It is basic linux. You can google how to use the vi editor. It is not the easiest editor.

1 Like

Hi Markus & mk2k,
Many thanks for your reply.

After some youtube tutorials, I think i managed to log on using Putty.
But somehow i end up with the same error on user rights…
Just like through FTP - i’m not able to edit the service-setup file.
When I open it with “VI” it also sais “read-only”.
To my knowledge I only have one account on the NAS.
Any suggestion how to fix this?

Kindly let me know if I’m missing something.

Thanks again for your help!


image

First elevate to root with sudo su -
(admin password)

if you see root@DS212: try again editting the file with vi.

sudo

1 Like

Hi Mk2k & Markus.
Thanks for your support.
I meanwhile have Sonarr & Radarr working again, bit clunky but it’s working… so i don’t complain!

I found this, which basically walked me through;



After this, with FTP through winSCP i was able to replace the “service-setup” and redirect it to Mono Beta. In additional I changed the filename of “Mono beta”.

It does however not automatically start when I use the restart function in Sonarr, so in that case I have to manually start in through DSM package manager.

Many thanks for your help!!!

There are some minor hicksup with post processing (for some reason it doesn’t automatically place the items in the correct folders), which I will probably overcome!

I will maybe be looking for a new Synology NAS later this year, looking at the above issues, is there any type you would recommend or opposite, absolutely avoid - taking into account I want to keep using Sonarr & Radarr? 2 (raid 1) or 4 (raid 5) bays.

BTW - would you recommend me to update to Sonarr v3 ?

Hi Topnotch14,

Good to hear you have it sorted. I see in the video it tells you to allow root login without sudo. Don’t forget to disable this again. It is a big security risk to leave it enabled.

Sonarr v3 did not work with this older Mono beta version. I reverted back to 2.x. But if you’re going to a newer NAS, I recommend using Docker. It is easier with upgrades and works very good.