Synology DS212J Sonarr failed to run package service

Sonarr version (exact version): v20200409-16
Mono version (if Sonarr is not running on Windows):5.2.1334-13
OS: DSM 6.2.3-25426
Debug logs:
Description of issue: synology restarted and i guess it installed latest versions of mono and sonarr. now sonarr wont start. gives me a “failed to run package service”. Can anyone help? maybe roll back to an old version???

I have the same issue. Ds212+ (arch: 88f6281 / armv5)
Updated the sonarr and mono packages from synocommunity.
Now sonarr cannot start anymore.
I even completly reset my synology to factory default (erase all data + new dsm install) . Did not recover any bacups or anything. So tried to install again on a clean DSM, both the mono and sonarr packages from the synocommunity repo. The same error occurs. Cannot start.
One of these packages is corrupted. How to revert back to older versions?

I cannot pick a version or find a spk to do manual install.

Install log:
admin@DiskStation:/volume1/@appstore/nzbdrone/var$ cat nzbdrone_install.log
Wed Jul 8 13:04:56 CEST 2020
===> Step preinst. USER=nzbdrone GROUP=sc-download SHARE_PATH=
Wed Jul 8 13:04:58 CEST 2020
===> Step postinst. USER=nzbdrone GROUP=sc-download SHARE_PATH=
Installing service configuration /var/packages/nzbdrone/conf/
Creating group sc-download
Group Name: [sc-download]
Group Type: [AUTH_LOCAL]
Group ID: [65536]
Group Members:
Invoke service_postinst
Granting ‘sc-nzbdrone’ unix ownership on /volume1/@appstore/nzbdrone/var/.config
chown: cannot access ‘/volume1/@appstore/nzbdrone/var/.config’: No such file or directory
Granting ‘sc-nzbdrone’ unix ownership on /volume1/@appstore/nzbdrone/var
Wed Jul 8 13:06:48 CEST 2020
===> Step preuninst. USER=nzbdrone GROUP=sc-download SHARE_PATH=
Removing service configuration
Wed Jul 8 13:06:49 CEST 2020
===> Step postuninst. USER=nzbdrone GROUP=sc-download SHARE_PATH=
Removing user sc-nzbdrone
Wed Jul 8 13:13:58 CEST 2020
===> Step preinst. USER=nzbdrone GROUP=sc-download SHARE_PATH=
Wed Jul 8 13:13:59 CEST 2020
===> Step postinst. USER=nzbdrone GROUP=sc-download SHARE_PATH=
Installing service configuration /var/packages/nzbdrone/conf/
Adding ‘sc-nzbdrone’ to ‘sc-download’
Group Name: [sc-download]
Group Type: [AUTH_LOCAL]
Group ID: [65536]
Group Members:
Invoke service_postinst
Granting ‘sc-nzbdrone’ unix ownership on /volume1/@appstore/nzbdrone/var/.config
chown: cannot access ‘/volume1/@appstore/nzbdrone/var/.config’: No such file or directory


admin@DiskStation:/volume1/@appstore/nzbdrone/var$ cat nzbdrone.log
Wed Jul 8 13:14:11 CEST 2020
Starting nzbdrone command env PATH=/volume1/@appstore/nzbdrone/…/mono/bin:me1/@appstore/nzbdrone/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/syno/sbin:/uso/bin:/usr/local/sbin:/usr/local/bin HOME=/volume1/@appstore/nzbdrone/var LRARY_PATH=/volume1/@appstore/nzbdrone/lib /volume1/@appstore/nzbdrone/…/mon/mono /volume1/@appstore/nzbdrone/share/NzbDrone/NzbDrone.exe
r4_conv_to_r8 R47 <- R44

  • Assertion: should not be reached at decompose.c:1891

Native Crash Reporting

Got a SIGABRT while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries
used by your application.

00010000-00369000 r-xp 00000000 fd:00 1282 /volume1/@appstore/mono/bio-sgen
00378000-0037f000 rwxp 00358000 fd:00 1282 /volume1/@appstore/mono/bio-sgen
0037f000-004d7000 rwxp 00000000 00:00 0 [heap]
40000000-40020000 r-xp 00000000 09:00 13662 /usr/lib/
40020000-40023000 rwxp 00000000 00:00 0
40023000-40024000 r-xp 00000000 00:00 0
40024000-40025000 —p 00000000 00:00 0
40025000-40026000 rwxs 00000000 00:10 219507 /dev/shm/mono.29851
40026000-4002f000 rwxp 00000000 00:00 0
4002f000-40030000 r-xp 0001f000 09:00 13662 /usr/lib/
40030000-40031000 rwxp 00020000 09:00 13662 /usr/lib/
40031000-400c9000 r-xp 00000000 09:00 15042 /usr/lib/
400c9000-400d8000 —p 00098000 09:00 15042 /usr/lib/
400d8000-400d9000 r-xp 00097000 09:00 15042 /usr/lib/
400d9000-400da000 rwxp 00098000 09:00 15042 /usr/lib/
400da000-400e0000 r-xp 00000000 09:00 15198 /usr/lib/
400e0000-400ef000 —p 00006000 09:00 15198 /usr/lib/
400ef000-400f0000 r-xp 00005000 09:00 15198 /usr/lib/
400f0000-400f1000 rwxp 00006000 09:00 15198 /usr/lib/
400f1000-400f5000 r-xp 00000000 09:00 12745 /usr/lib/
400f5000-40104000 —p 00004000 09:00 12745 /usr/lib/
40104000-40105000 r-xp 00003000 09:00 12745 /usr/lib/
40105000-40106000 rwxp 00004000 09:00 12745 /usr/lib/
40106000-4011b000 r-xp 00000000 09:00 15338 /usr/lib/libpthread-2.15.s
4011b000-4012b000 —p 00015000 09:00 15338 /usr/lib/libpthread-2.15.s

Basic Fault Adddress Reporting

Memory around native instruction pointer (0x40177fa0):0x40177f90 03 10 a0 20 a0 e1 43 7f a0 e3 00 00 00 ef … …C…
0x40177fa0 01 0a 70 e3 08 00 00 8a 90 40 bd e8 1e ff 2f e1 …p…@…
0x40177fb0 00 00 50 e3 f5 ff ff ca 02 21 c0 e3 00 00 52 e3 …P…!..
0x40177fc0 00 00 60 12 03 00 a0 01 f0 ff ff ea 00 10 60 e2 …`…

Native stacktrace:

    0xf2164 - /volume1/@appstore/nzbdrone/../mono/bin/mono : (null)
    0xb39d4 - /volume1/@appstore/nzbdrone/../mono/bin/mono : (null)
    0x40179370 - /lib/ : __default_rt_sa_restorer_v2
    0x40177fa0 - /lib/ : gsignal
    0x4017bea8 - /lib/ : abort
    0x298cd0 - /volume1/@appstore/nzbdrone/../mono/bin/mono : monoeg_asabort
    0x2828e8 - /volume1/@appstore/nzbdrone/../mono/bin/mono : (null)
    0x27d350 - /volume1/@appstore/nzbdrone/../mono/bin/mono : (null)
    0x298c78 - /volume1/@appstore/nzbdrone/../mono/bin/mono : (null)
    0x298f14 - /volume1/@appstore/nzbdrone/../mono/bin/mono : monoeg_ason_message
    0x7ddc4 - /volume1/@appstore/nzbdrone/../mono/bin/mono : (null)
    0xf8988 - /volume1/@appstore/nzbdrone/../mono/bin/mono : (null)
    0xf9218 - /volume1/@appstore/nzbdrone/../mono/bin/mono : (null)
    0x38ffc - /volume1/@appstore/nzbdrone/../mono/bin/mono : (null)
    0xb7184 - /volume1/@appstore/nzbdrone/../mono/bin/mono : (null)
    0xb7810 - /volume1/@appstore/nzbdrone/../mono/bin/mono : (null)

Telemetry Dumper:

Pkilling 0x41d49450 from 0x400217c0
Entering thread summarizer pause from 0x400217c0
Finished thread summarizer pause from 0x400217c0.

Waiting for dumping threads to resume

Debug info from gdb:

External Debugger Dump:

mono_gdb_render_native_backtraces not supported on this platform, unable to gdb or lldb

Managed Stacktrace:

      at <unknown> <0xffffffff>
      at System.Collections.Hashtable:.ctor <0x0002b>
      at System.Configuration.Configuration:.ctor <0x0002f>
      at System.Configuration.InternalConfigurationFactory:Create <0x00
      at System.Configuration.ConfigurationManager:OpenExeConfigurationnal <0x00383>
      at System.Configuration.ClientConfigurationSystem:get_Configuratix00043>
      at System.Configuration.ClientConfigurationSystem:System.Configur.Internal.IInternalConfigSystem.GetSection <0x00017>
      at System.Configuration.ConfigurationManager:GetSection <0x00047>
      at System.Configuration.ConfigurationManager:get_AppSettings <0x0
      at NLog.Common.InternalLogger:GetAppSettings <0x00013>
      at NLog.Common.InternalLogger:GetSettingString <0x0002b>
      at NLog.Common.InternalLogger:GetSetting <0x0002b>
      at NLog.Common.InternalLogger:Reset <0x0002b>
      at NLog.Common.InternalLogger:.cctor <0x00033>
      at System.Object:runtime_invoke_void <0x00073>
      at <unknown> <0xffffffff>
      at NLog.Config.LoggingConfiguration:Dump <0x00053>
      at NLog.LogFactory:set_Configuration <0x001b7>
      at NLog.LogManager:set_Configuration <0x0002f>
      at NzbDrone.Common.Instrumentation.NzbDroneLogger:.cctor <0x0002b
      at System.Object:runtime_invoke_void <0x00073>
      at <unknown> <0xffffffff>
      at NzbDrone.Console.ConsoleApp:.cctor <0x00017>
      at System.Object:runtime_invoke_void <0x00073>


DSM was recently updated to 6.2.3, so I downgraded back to 6.1 and tried again Mono and Sonarr from the synocommunity repo. Same problem. One or both of the packages are corrupt.

Versions used / failing :

Sonarr: 20200409-16

DSM: 6.1-15047
DSM: 6.2.3-25426

If someone can post links to previous versions of mono and sonarr that would be great!

If working packages for mono and sonarr can be added to the repository, that would be great.
Dont see any option to revert/install older versions.

if old packages can be listed you can do a manual install through DSM i think


I managed to get sonarr working again :slight_smile: with the help in this topic: Sonarr fails to start on Synology after latest package update

What I did:
installed this mono package manually:

Changed the monopath in service-setup file in /var/packages/nzbdrone/scripts
to MONO_PATH="/var/packages/Mono/target/usr/local/bin"

Then Sonarr works again using the other mono package you installed manually (it has a capital letter M in Mono).
I went straight for v3.x of sonarr and installed this package instead of v2.x from the synocommunity:

Sweet! Glad my post helped and thanks for the link to v3!

Hi mk2k,
thanks for getting back to me and congrats on finding a work around using Shannon’s original post!

I tried editing the service-setup file using a putty session and vi but it wont let me write new line as the file is read only. i tried using chmod 777 service-setup in the command line and it says operation not permitted. do you have any insight? any help is appreciated


you should be able to edit the file running vi as root. so if you run

sudo vi /var/packages/nzbdrone/scripts/service-setup

you should be able to edit the file if you press i without a readonly error.


I just reverted back to v2 package from synocommunity. the v3 package was unable to make a connection to the internet. unable to connect to indexer, unable to fetch updates etc.

I think because of the old mono version I installed as workaround. I found elsewhere in this forum mono v5.20+ is recommended for sonarr v3.

Installed Sonarr v2 and looks like it’s working fine with the mono v4.6.2 as far as I can see now. I was able to update to latest version of Sonarr. Now running

Hi mk2k,
i followed your advice

  1. manually installed mono (old version)
  2. installed v2 of sonarr from synocommunity. sonarr gave me a warning message that it was installing Mono. If i said “no” it wouldnt install, if i said “yes” it installs the flawed version on Mono.
  3. if i make the edit change to the monopath using the sudo vi command you gave and then try to start sonarr, sonarr says, “running” and then it just stops i.e. hit run, and the cycle continues.

how did you install sonarr after you manually installed mono? it seems sonarr wont install unless you put that flawed version of Mono on the synology?

sorry for all the questions, its been working for years. lesson learned, never update if its working!


@deltasniper Correct, I also let it install bad / non working mono package.
After installing sonarr, uncheck the option to start after installing.

Then with putty ssh into your DS and edit the service-setup in vi (as root) after you changed the path to the Mono package with capital M, save file.

Now start sonarr from the package manager. It should start fine.
You can check the log it’s on my ds212 in this location: cat /volume1/@appstore/nzbdrone/var/nzbdrone.log

You can check here if it’s running okay. I see at the bottom of the file:

[Info] OwinHostController: Listening on the following URLs:
[Info] OwinHostController: http://*:8989/
[Info] NancyBootstrapper: Starting Web Server

it works!
there is only one small change, for any future unfortunate treading this path




i guess the lower case mono is the bad version!

Thank you @mk2k for your help you are a rockstar!

@mk2k Yeah, I had to do the same. Seemed like an issue with the certificate authentication but I didn’t want to screw with it anymore so I too just reverted back to Sonarr v2 and everything worked.

It might be worth messing with at some point in the future but for now, I’m just glad to have core functionality returned.

and thank you too @SDShannonS :slight_smile:

No problem @deltasniper
You are correct, mono with small letters is the wrong / corrupted version and the one with the capital letter M is the one you installed manually.

@SDShannonS Good you got everything sorted out, thank you also for your initial post and help :smiley:

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.