Getting started - Not importing


#1

Sonarr version 2.0.0.5322:

Windows 10 1809

I need someone to explain about the logs and “pastbin” why I need it, or dropbox, I have google drive… someone explain why or what I need to do to get the logs here.

I’m getting “Disable TV Sorting” in my download client Sabnzdb and an error when I try to test it.

Also, my downloads are ending up in a completed folder, but not in the C:/TV folder and the specific show folder.

I’ve installed Radarr, Sonarr, and Lidarr all on the same system, initially wanting to get Sonarr and Radarr working.

I’m using PLEX, MicroTorrent (some people call it utorrent incorrectly) and my Windows 10 PC is actually a VM on a HYPER V on my main pc.

Plex works fine, sometimes Movies and TV shows will show up in Plex that have been downloaded using either Sonarr or Radarr but they are not in the correct folder and I have not moved them manually.

Files are staying in Microtorrent, I don’t want them running forever using up my bandwidth, if I can’t do a 1:1 share, then I’d rather smash and grab.

Sorry for all this, I considered using the Discord channel but this is too much, I think.


#2

Read the wiki page for the log files, we want debug logs to see what Sonarr sees, especially when things fail to import. We ask that they are posted elsewhere then linked here instead of filling the thread with a giant log file.

You need to disable that in SAB’s sorting settings.

Perhaps because SAB’s sorting is messing it up for Sonarr, but debug logs will give us more info.

Are SAB, Plex and uTorrent (yes it’s mu, not a u, but honestly no one cares) on the same machine?

They also aren’t moving from utorrent?

Without knowing more, either Sonarr can’t access the files due to permissions (less common on Windows), or it simply can’t find them, (not on the same machine as the download client) so the reported path from SAB/utorrent is meaningless.


#3

Body is limited to 32000 characters; you entered 137051.

Everything worked previously with TV and MOVIES enabled,

You did not explain how to post log file, and i don’t get the link on how to post the log file. I know where the log file is. I know how to access it, how to copy it, how to paste it, it won’t fit.

Read the wiki page for the log files , we want debug logs to see what Sonarr sees, especially when things fail to import. We ask that they are posted elsewhere then linked here instead of filling the thread with a giant log file.

READ IT, don’t understand what to do once I get it to another site, you still need the log file.

As I said, it’s on a VM using Hyper V, so yes, PLEX, RADARR, SONARR, LIDARR all on the same system. PORTS all to the same IP of the VM, not the box the VM is on, I understand that much.


#4

Upload the log file elsewhere and then paste a link to it here, either drop the file on google drive and get the public link or copy the contents to pastebin/hastebin, upload and post the link here. pastebin/hastebin is just a site for posting blocks of text for linking elsewhere.


#5

Sorry, I cleared it, as it had outdated data as I’m messing with things while I wait to get a solution to my problem.


#7

And here’s the Radarr link:

https://drive.google.com/file/d/1YjPOyrK38qfZIymnGazUkOp7KAwxdPjY/view?usp=sharing

And I’m getting sick of RADARR downloading 20+ GB replacement files when I didn’t ask to replace my movies in the first place. It’s eating up my monthly bandwidth from my ISP. It has to stop.

Also, on my SONARR, I’ve watch ONE, count them ONE episode of Bill Mahr and I get nothing but shit from sonarr about it and I’ve deleted it from my library in Sonarr.

Don’t you think this should be something that I (me) should be able to diagnose? Shouldn’t there be instructions on how to interpret and fix your Sonarr and Radarr from the LOGS instead of POST YOUR LOGS and WE’LL DO IT FOR YOU…

JUST MY THOUGHTS.


#8
  1. Those aren’t debug logs
  2. You need to post them elsewhere (I’ve deleted them because they don’t show anything relevant)

You watched then deleted it? Then Sonarr will think it’s missing unless you tell Sonarr to unmonitor it (or tell it to unmonitor on delete, there is a setting for that).

The logs will tell you what’s wrong, from that you can figure out how to fix it, that’s all we’re doing, there isn’t any magic. It’s more the knowledge of what could be wrong if you see a specific error.

You’re going to need to go elsewhere for support with Radarr though.


#10

It’s not very long, don’t know why it would need to be posted elsewhere:

19-4-28 02:21:06.9|Debug|SabnzbdProxy|Url: http://localhost:8080/api?mode=get_config&apikey=(removed)&output=json
19-4-28 02:21:06.9|Debug|SabnzbdProxy|Url: http://localhost:8080/api?mode=get_config&apikey=(removed)&output=json
19-4-28 02:21:07.0|Debug|Api|[PUT] /api/config/host: 202.Accepted (331 ms)
19-4-28 02:21:07.1|Debug|Api|[GET] /api/health: 200.OK (0 ms)
19-4-28 02:21:07.2|Debug|Api|[GET] /api/health: 200.OK (1 ms)
19-4-28 02:21:07.9|Debug|SabnzbdProxy|Url: http://localhost:8080/api?mode=version&apikey=(removed)&output=json
19-4-28 02:21:07.9|Debug|SabnzbdProxy|Url: http://localhost:8080/api?mode=version&apikey=(removed)&output=json
19-4-28 02:21:07.9|Debug|SabnzbdProxy|Url: http://localhost:8080/api?mode=fullstatus&skip_dashboard=1&apikey=(removed)&output=json
19-4-28 02:21:07.9|Debug|SabnzbdProxy|Url: http://localhost:8080/api?mode=fullstatus&skip_dashboard=1&apikey=(removed)&output=json
19-4-28 02:21:07.9|Debug|Api|[GET] /api/health: 200.OK (1 ms)
19-4-28 02:21:07.9|Debug|Api|[GET] /api/health: 200.OK (0 ms)
19-4-28 02:21:10.4|Debug|SabnzbdProxy|Url: http://localhost:8080/api?mode=queue&start=0&limit=0&apikey=(removed)&output=json
19-4-28 02:21:10.4|Debug|SabnzbdProxy|Url: http://localhost:8080/api?mode=history&start=0&limit=30&category=tv&apikey=(removed)&output=json
19-4-28 02:21:10.4|Debug|Api|[GET] /api/queue?sort_by=timeleft&order=asc: 200.OK (0 ms)
19-4-28 02:21:10.7|Debug|Api|[GET] /api/health: 200.OK (1 ms)
19-4-28 02:21:10.7|Debug|Api|[GET] /api/health: 200.OK (1 ms)
19-4-28 02:21:10.7|Debug|Api|[GET] /api/diskspace: 200.OK (37 ms)
19-4-28 02:21:10.8|Debug|Api|[GET] /api/diskspace: 200.OK (23 ms)
19-4-28 02:21:11.9|Debug|Api|[GET] /api/log?page=1&pageSize=50&sortKey=time&sortDir=desc: 200.OK (2 ms)
19-4-28 02:21:12.0|Debug|Api|[GET] /api/log?page=1&pageSize=50&sortKey=time&sortDir=desc: 200.OK (1 ms)
19-4-28 02:21:13.4|Debug|Api|[GET] /api/log/file: 200.OK (1 ms)
19-4-28 02:21:13.4|Debug|Api|[GET] /api/log/file/sonarr.debug.txt: 200.OK (1 ms)
19-4-28 02:22:01.4|Debug|Api|[GET] /api/log/file/sonarr.debug.txt: 200.OK (1 ms)

https://drive.google.com/file/d/1HlUkjElb6MHn01l9lBwuj8_08w18790D/view?usp=sharing


#11

It’s not very long because there is nothing there (just enabled debug by the looks of it). It’s also a pretty good indication if someone can follow simple instructions…

There are several issues with the files already in the series folder, which means Sonarr can’t properly determine you have the files already, beyond that I don’t see issues importing files from the download client in that particular log.

  1. C:\TV\Doctor Who 2005\Season 04\DrWho2005, 2008-04-19, S04E03, Planet of the Ood (tt0436992).avi - If you want to include the date and the season + episode numbers the date should come after the season and episode number
  2. C:\TV\Absolutely Fabulous\Series 3\Absolutely Fabulous - 3xS1 - The Last Shout Part 1.avi - 3xS1 makes no sense to Sonarr as a number, that should either be 3x01 or S03E01
  3. C:\TV\Avatar - The Last Airbender\Book 3 - Fire\Ep. 50 - The Day of Black Sun Part 1 - The Invasion-[720p].mkv - That numbering would be fine, but it looks like Absolute episode numbers aren’t set for that series, so you’re either going to need to get them added on TheTVDB or rename to S03Exx
  4. C:\TV\The Good Doctor\The.Good.Doctor.S01E11.WEBRip.x264-RARBG.mp4 Maybe this is one that didn’t import? That’d be due to sorting in the download client. You should have your download client put files in a completely separate folder, such as C:\Downloads\TV

There may be additional issues, but those ones popped up as a took a quick peek at the logs.


#12

Right now, it appears that SABnzbd is not passing, when I click test, it fails and asks me to clear the category, but categories re set up in SABnzbd. Also, I’ve clicked on some TV shows, and they appear to download, and go into the right folder, but there clearly are errors.


#13

Clear the logs. run the test, upload the logs and put the link to them here. You seem to be trying to troubleshoot multiple things at once.

and 4.

You should read the document at the below link, twice. It will help you get the help you are searching for.
http://catb.org/~esr/faqs/smart-questions.html

IMHO, the documentation on how to post debug logs wasn’t clear to you, why would documentation on how to interpret the logs be easier for you to understand? TBF, you didn’t even follow the directions to do a search before posting or you would have found previous topics with the same issues (see below link). So, whether or not anyone here thinks you should be able to diagnose your own problems becomes irrelevant, because being able to follow simple instructions is a prerequisite for even the simplest troubleshooting.

https://forums.sonarr.tv/search?q=%22Disable%20TV%20Sorting%22&expanded=true


#14

[quote=“beardman, post:13, topic:22152”]
IMHO, the documentation on how to post debug logs weren’t clear to you, why would documentation on how to interpret the logs be easier for you to understand?[/quote]

“weren’t” should be “wasn’t” but as unclear as THAT was, I figured your poor English out.

I know how to ask questions, Cockmonkey, thanks for the reading though.

Here is one search string I did on Google before I came to this forum:

sonarr all download clients are unavailable due to failures sabnzbd

Which yielded these websites I visited:

Additionally, I did other searches, Cockmonkey, but I won’t waste everyone’s time posting them here.

The posts YOU linked were mostly stale, but I had ALREADY (BEFORE POSTING COCKMONKEY) REMOVED TV AND TRIED THAT, thank you very much.

I’ve worked in the computer industry for 35 years. I started on an XT. 95% of the time, when I go to a link, like this websites on how to get the logs, I expect it to be dumbed down for the average user, which I am not.

So, I initially glazed over the link and felt that I knew what and where the log files were, I was mistaken on that point and I apologize for my arrogance in that matter.

No matter if I have “TV” category entered or not, SAB errors out. When I remove the TV category, SAB tells me that it recommends a category.

I have cleared my log, and am allowing the new log to fill up with data so that I may post an new log for review. I too will review it and see if there is anything in there that I, myself, can interpret.

Thanks for trying to point out where you think I was being


#15

https://drive.google.com/file/d/1YMDBGiJIlix_3hcwdXGau42o2FC9b_TP/view?usp=sharing


#16

It sounds like there is confusion on how the directories and download work together based on Sonarr and your news/torrent client. I did a visual flow of how the different directories and such work so it may be helpful to draw out the flow and where files are dropping and to what location so the mapping is clear. I’m primarily a Linux user as the concepts are the same so I used some example Windows paths.

NZB Client

Torrent Client

Not quite a perfect wording/rendition, but I think it gets the idea across.


#17

That all seems logical.

SAB, however, is my NZB client (if I truly understand things) and when I was following the instructions (because I don’t google instructions apparently) the recommendation was that I enter a category in the SAB Download Client TV for Sonarr and Movie for Radarr.

When I click, “TEST” It says that “Category does not exist”

When I remove the category, “A category is recommended” and SAB still fails.

HOWEVER, now, TV shows do appear to be downloading and going into appropriate folders, just the settings are not right.

I guess this is just JINKY and I have to accept it with flaws… like all the other software in this category that came before that kept me from entering this arena… now I enter and find out it is the same.


#18

Do you have a screenshot of your SABNZB category config and a screenshot of what you are entering in Sonarr?


#19

Thank you. I missed that one.

I am sorry if I wasn’t clear. I meant searching these forums, not Google.

Yep, they were old posts. They also had the same problem you have, and at least one of them had the same misunderstanding that we are having here. The TV category does not need to be removed (it needs to be there); the TV sorting needs to be turned off, because it conflicts with Sonarr’s Completed Download Handling.

Of course you do. I did not mean to imply that you didn’t know how to ask questions. I also did not intend the link to be an insult; though, it seems you took it that way. That document is an excellent resource. I have read it many times, and I still find it useful, especially as a reminder to limit my troubleshooting to the initial issue, rather than confuse the issue by trying to attack unrelated problems or problems that are actually symptoms of the initial issue.

You don’t need to let the log fill up. Just clear the logs, turn debug on, recreate the error, turn debug back off, post the log. This should preferably be done outside of rss syncs, searches, or anything else that will put unrelated items in the logs.

@Animosity022 I leave the rest to you.

@YEN Good Luck :sunglasses:


#20

https://drive.google.com/file/d/1jvhBHIeJKaPwvIAGk4TnVMvrV0yazESH/view?usp=sharing

https://drive.google.com/file/d/1c-E3fnJQBUqZ-D5uRQP3ZxtqX_WEneCw/view?usp=sharing

https://drive.google.com/file/d/1W5_SkhtR1Xkx6zfWz3cki3B8KfxtDXoB/view?usp=sharing


#21

It’s case sensitive so you need to use little ‘tv’ as opposed to ‘TV’.


#22

Was pretty sure I did that… and I did, still persists.

Wasn’t being a dick here, was testing while typing…