Waiting to import

Sonarr version (exact version): 3.0.9.1549
Mono version: 6.8.0.105
OS: Debian 11.4

This has been happening for a while and decided to finally make a post about it.

Whenever my friends request a TV show, I have things set up on my side so their requests are grabbed in whatever format is available but HEVC/265 is preferred. If a show only has a 264 version, Sonarr grabs it and when the 265 version comes along a few hours later, Sonarr downloads -that- version and it replaces the 264 copy and all is well.

BUT, every now and then, something gets out of alignment and it’s the same problem. Example, Last Week Tonight with John Oliver…

Sonarr downloaded S10E02 (the 264 version) last night and it got added to the right folder and shows up in Plex.

A little bit later, the x265 version popped up on Usenet and Sonarr downloaded it, and successfully imported it into the proper folder and it’s in Plex.

However, in the download folder, I still have the 264 version and in Sonarr>Activity, I have this error:

Downloaded - Waiting to Import

One or more episodes expected in this release were not imported or missing

last.week.tonight.with.john.oliver.s10e02.720p.web.h264-glhf.mkv

Not a preferred word upgrade for existing episode file(s)

If I simply go into the Queue and delete the stalled download and refresh the series, the error disappears and life goes on. In an average week, I’d guess that 20 episodes are upgraded from the 264 version to their 265 equivalent and I run into this problem with 1 or 2 episodes and I need to go into Sonarr’s queue and nuke the stalled download.

I don’t know why the majority of these downloads/264 to 265 conversions go off without a hitch and only a fraction of them need intervention.

I did some searching on the forum and found this

…same bug?

Before the x265 release is grabbed is the x264 release stuck in the queue with the same error as the thread you linked? There should be something in the logs as well.

What does the history look like for that episode?