Unable to connect to SABnzbd, please check your settings


#1

Sonarr version (exact version): 3.0.1.441

Mono version (if Sonarr is not running on Windows):
OS:
Debug logs: https://paste.kodi.tv/watidahaxu
Description of issue:
hi guys, first time poster. I’ve had Sonarr about 2 months and it’s been great, thanks devs. This error started a few days ago “unable to connect to sabnzbd” Both are on the same pc running Win10
Things I’ve done:
restarted Sonarr and Sab
turned off firewall
removed client from Sonarr and tried to add again
updated to Sonarr 3.0
The only change to the pc was windows updated 2 days before I discovered the problem. I’d like to see if there’s a simple fix before I roll back Windows update.
tia


#2

Looks like one of your settings in Sonarr for SABnzbd may be wrong (or you’re using a really old version of SAB).

Trace logs may show you exactly what SAB doesn’t like about the request Sonarr is making.


#3

hey markus, my Sab is current and I never made any changes to Sonarr settings, it just stopped working. I’ve tried just about every possible setting scenario and still no luck. Btw, I forgot to mention that Sonarr also stopped seeing my download folder. I manually put a couple files in there and it’s not working. I loaded SB and it still works with the same settings. Would you like me to up a new debug?


#4

Post a trace log, a new debug log won’t show anything more.


Unable to connect to SAB, please check your settings
#6

here you go, thx
https://paste.kodi.tv/fobuboqabu


#7
The client sent a plain HTTP request, but this server only speaks HTTPS on this port.

Looks like the port you’re using is set for HTTPS, not HTTP, either enable SSL in Sonarr’s settings or use the correct port.


#8

I don’t think that’s it markus, I’ve tried with ssl on/off https in Sab on/off, nothing. It should’ve showed that in the log, I did it both ways.


#9

And the HTTPS connection failed because the certificate validation failed.

19-4-14 14:23:11.1|Error|X509CertificateValidationService|Certificate validation for https://localhost:8080/api?mode=version&apikey=(removed)&output=json failed. RemoteCertificateChainErrors

In v3 certificate validation is enabled by default, you can disable it for local or all addresses (the recommendation being local only unless absolutely required to disable it globally).

I missed this in your original log file, but both these issues are logged there.


#10

That did it!!! Thank you markus, you’re awesome!