Unable to access domain post v3 upgrade

Sonarr version 3.0.6.1196
Mono version 6.12.0.122:
OS Ubuntu 16.04.7 LTS:

I’ve been running Sonarr for at least 5 years, and it was working perfect in v2. Yesterday I upgraded to v3 and ever since, I cannot hit it via http or https unless I use the IP. The domain is resolving properly, because https://kc-felty.net/radarr is working fine, but https://kc-felty.net/sonarr, which worked on v2, is not working on v3. I can hit via http://:8989. I have been fighting this for 2 days and am unable to figure out why it isn’t working after the upgrade.

I am a UNIX systems administrator with 40 years experience, 24 years Linux experience, and have worked in hosting for 20 years, so I know a bit about configuring webservers, but this one has me stumped.

Additional Information:
https://pastebin.com/43nsQqqm - sonarr debug log
https://pastebin.com/KgLmaL6c - system log (tailed 500)
https://pastebin.com/WV88bKKU - apache error log

Any help would be appreciated. I am working hitting via local IP, but I have it set for SSL and domain resolution so I can hit my Sonarr when outside the home.

Also, just to show resolution is working:

root@REZ:~/.config/sonarr.backup# ip a | grep tun
26: tun0: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN group default qlen 100
inet 192.121.247.37/26 brd 192.121.247.63 scope global tun0

root@REZ:~/.config/sonarr.backup# nslookup kc-felty.net
Server: 8.8.8.8
Address: 8.8.8.8#53

Non-authoritative answer:
Name: kc-felty.net
Address: 192.121.247.37

I do everything on the sonarr/radarr/transmission/plex server through a VPN with foreign endpoints, which changes hourly and uses dyndns, so I always check resolution first thing.

Start simple.

Settings general -> what is sonarr bound too, is the baseurl set?

And what’s the Apache settings look like for sonarr?

urlbase /sonarr
apache.conf https://pastebin.com/5Nm8WCfi
HiRez_L apache2 sites-enabled default.conf https://pastebin.com/YD7fXmxq
HiRez_L apache2 sites-enabled default-ssl.conf https://pastebin.com/QTyY5HRn

After reading this post:

I found that my domain is accessible via kc-felty.net/sonarr using MS Edge, just doesn’t work with Chrome or Firefox.

Has Edge specific code been added in v3?

My understanding was that Edge was built on Chromium code, the same as Chrome.

Has Edge specific code been added in v3?

Nope

I’d use wireshark to check the traffic. tbh, it might just be an url difference or cookie. try chrome incognito for example.
The system log shows a ton of authentication errors, where do those come from?
The posted apache config is basically just the global one, not the sonarr/radarr part. You’re forwarding auth or terminating auth?

Not sure about the auth errors. I sent all the apache confs I have. Using an incognito window, Firefox and Chrome work fine, so you must be right, some caching or cookie issue, I’ll trace it down.