Sonnar on Synology and USeed

Sonarr version (exact version): 2.0.0.5344 - 13/03/2020
Mono version (if Sonarr is not running on Windows): 5.20.1.34-16
OS: Synology NAS

Dear All
I’m new to Sonarr, and I am lost in the parameters.
I use a Synology DS918+ for Sonarr, and a Useed Box to download.

Now, Sonarr can find the torrents, and downloads them on Useed, by the process stops afterward, I have now download from USeed to ny NAS, and of course no renaming.

If this topic has already been explained, sorry, I did not find it.

Thank you for your support

Erik

im presuming that useed is some sort of external download client service, not something local to your nas or network.

you probably need a remote path mapping so sonarr can tell where the useed path really is located

the logs should show what the path useed is giving back for the completed job, you just need the remote path mapping to convert that path into something sonarr can use to actually access it.

Thanks for your answer.
Where is the parameter for Path mapping?

this is from v3, not v2 but i think its in the same place

ok, so you have one already - thats good but im not sure its setup correctly. its still pointing to (what looks like) a local path

whats the error message on the failed imports, that will tell you where its trying to import from

That’s the point, I have no error message, I’m not sure sonarr tried to download the files

whats on the activity page? anything listed with an orange icon on the right? (wants help)

this old thread may help

I have found in the logs some more information:
Couldn’t process tracked download Your.Honor.S01E09.1080p.WEB.H264-GGEZ[rarbg]: Access to the path ‘/etc/postgresql’ is denied.
What I understood is that “Remote path” is the path on the USeed box
and local path is the one on the NAS

that seems to indicate that whatever account sonarr is running as cant access that local path. youll need to check the permissions to confirm it can.

yes, you convert part of the remote path to a local path that sonarr can see and access.

that old thread says that useed will work with webdav. you may need to wait for someone with more knowledge of that side of things as ive never used it.

you may also want to check if useed has any doco on working with sonarr

its probably also a good idea to set the log level to debug, then leave it for a while and upload all the debug logs (zipped) somewhere t.hey can be accessed online so we can see whats going on. theyre going to be needed at some point

Thank you rhom for your help.

Actually I don’t know on wich user is running Sonarr

is it the sonarr package from the synocommunity site?

its v2 on dsm so i think there is a start file somewhere (possibly under @appdata, sorry i havent used that version for a long time) and it has an entry for it, it used to be user=sonarr - the syno community site may have instructions on where it is and how to change it.

i used to change it to admin (as i had no external access to it so wasnt too fussed about security back then) so maybe check if you have a user named sonarr in dsm? if you do you can make it an admin to see if that fixes the issue.

Hello

Yes, it’s the package from synocommunity.
But I downloaded th eV3, and I still ahve the same message

I do not have any sonarr user in DSM, just a goup called “sc-download”, that has read/write access to the video directory

it sounds familiar but as i said, i havent used v2 (or the syno community version) for a long time. i use docker and the linuxserver/sonarr image

check if sc-download is a member of the administrators group, (dsm > control panel > group) and if not temporarily add it in there and see if that helps

if you have SSH enabled then maybe log in and check if /etc/postgresql exists. i checked mine and it doesnt exist in my DSM, or the docker container. its possible that path is for useed and theres an issue on their end?

Hi Same problem on V3
I din’t now how to check the directory with SSH
(I can connect with SSH, but I don’t now more)

Thanks

sudo -i
enter the admin password again
if you dont do the sudo to gain root access youll get a permissions error
cd /etc/postgresql

if you get -ash: cd: /etc/postgresql: No such file or directory then it doesnt exist, otherwise it does

i must have screwed up when i checked mine before as it is there now

Hello,

The directory exists…

add the sc-download user to the administrators group.
stop and start the sonarr package.
see if that helps.

Hello

Sc-download is a group, not a user.

I also had Sonarr deleting all the subtitles from TV Show.
So I gave up, and uninstalled it.
Too complicated for someone that does not know
Anyway, thank you rhom for you supprot.

Erik