Sonarr will not connect to remote server - potentially Virgin Media issue?

Sonarr version (exact version):
Mono version (if Sonarr is not running on Windows): N/A
OS: Windows 10
Debug logs: Issue with Virgin Media IP Address · GitHub
Description of issue: I installed Sonarr yesterday, and I’m having some issues when trying to update my library. Everything else appears to be set up correctly, but I get an error that the remote server cannot be reached, with the IP address of (shown in logs). I havent set up any port forwarding or anything like that, and when I asked on reddit, people there suggested it is likely a network issue.
I know virgin tends to block torrent sites and things of the likes, but I have been manualy downloading torrents with a VPN for a while, and can still do this. I have also tried turning off the VPn but this also hasnt worked.
Is anyone able to give me some guidance? I have set up my indexers and download clients, havent forwarded anything yet, so not sure if there is something i have to set up on my router?
Also, if anyone can give me some guidance on what it is specifically failing on, as this may help me narrow down my search.
Also, if anyone has set up Sonarr with Virgin Media (UK) broadband, i would appreciate to know if you have had a similar issue.
Thanks in advance.

v2 has been EOL for 3 years. Create a Sonarr backup.

Update to v3 -

Ensure there are no further issues, and create another backup.

Update to v4 -

See if the issue continues. If so, follow the steps here - "Unable to connect to remote server" since new server last month (hello from Reddit).