Sonarr failed to load, trying workaround, but running into error accessing file in putty

I understand this is a Synology question (old NAS DS411), but any help without trying to workaround would be useful also.

Sonarr version (exact version): 20201116-19 (also tried 20200921-18 and had same error)
Mono version (if Sonarr is not running on Windows): 5.20.1.34-17 (also installed 4.6.2-0096) for workaround thread below.
OS: Synology DSM 6+
Debug logs: below
Description of issue:

Issue 1: Sonarr “failed to run the package service” error after updating. Mono was automatically udpated as well. Appears to be a known issue with the ARM based synology - seems like a number of updates for the Sonarr package try to address this… I have also tried rolling back to 2019 version of Sonarr (even installed manually) but had problems.

Issue 2 (workaround to issue 1): I am following some of the steps indicated in the last post here: Sonarr fails to start on Synology after latest package update

However, I am getting permission denied even as a root user to access /var/packages/nzbdrone/scripts/service-setup. Also, I have the “could not chdir to home directory” as the first line, so I am not sure if that is affecting anything?

Any suggestions?

I have been meaning to upgrade to a new NAS but do not want to drop $750 for a 1520+ and $400 for new drives (I would just use the old drives - only have 8 tb in SHR) but would want to create a new volume >16tb in the future anyways…

Log for Issue 1:
https://drive.google.com/drive/folders/1bZbYQrJmM7w_HItofbpPBx-phWNswpBV?usp=sharing