Manual Import Modal "Glitchy"

Sonarr version (exact version):
Mono version (if Sonarr is not running on Windows):
OS: Ubuntu 18.04.3 LTS
Debug logs:
Description of issue: So this is probably more than 1 issue, but i figured they are coordinated/related somehow, so probably best to just to one post…
It all starts with the “Manual Import” under “Wanted”… I:

  • Go into the modal
  • Select a folder (folder1) to scan for import
  • Select import (everything auto-matched-up correctly)
  • Go into the modal again
  • Select another folder (folder2) via the folder icon button
  • I get “unable to load manual import items” … I’m guessing this is because you can’t have multiple imports running concurrently? Would be nice to have better messaging for that case
  • Cancel out of the modal
  • Wait for the import of folder1 to complete
  • Go back into the modal
  • Select the folder2 path again from the history (not the folder icon)
  • Still get the “unable to load manual import items” … This is a bug/glitch somehow with caching or something
  • Cancel out of the modal
  • Go back into the modal
  • Select the same folder2 path, but this time by navigating to it via the folder icon button… now the scan works correctly, everything matches up and i can import again

Ultimately it seems to be caching that error state when you select a folder path in the history part of the modal. This is the issue. The comment about better error messaging is obviously more of an enhancement, better still would to be allow queuing of import jobs somehow.

At this point there isn’t any import running concurrently. If it got to the point where you told it to import then it’d it’d queue the second import.

Based on the logs the request is successful, after almost a minute:

19-10-25 22:44:47.2|Debug|Api|[GET] /api/v3/manualimport?folder=%2Fhome%2Fmediaman%2Fmediaarchive%2Ftvarchive%2FAirwolf%2FSeason%2004%2F&filterExistingFiles=true: 200.OK (54235 ms)

Are you using a reverse proxy that is timing out before Sonarr responds?

When the modal is closed the UI clears out any information for that manual import, including folder selection and the error message. I’ve tried to reproduce this error, but I’ve been unable to.

It’d be good to know what the browser sees for those network requests (from the dev tools), it’s as if the second attempt gets the exact same network response, but I see multiple successful requests in the logs for /api/v3/manualimport and no failures.

After doing some digging based on your comments above, it does seem to be some kind of timeout… am tinkering with my reverse proxy (nginx) and cache (cloudflare) to see if i can figure out where the timeout is… interestingly, things worked “just fine” when i moved the files off of an rclone/remote-storage mount and to a local disk, seemingly because things just processed a lot faster being local… so i’ll dig further and report back here if i find the culprit.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.