Maddening Permission Issues

Sonarr version (exact version): 2.0.0.5344
Mono version (if Sonarr is not running on Windows):5.10.1.57
OS: OSX
Debug logs: https://pastebin.com/T4ULCpTd
Description of issue: Getting access to path is denied and unable to write to folder. However, I’ve CHMOD the directory recursively to 777, changed owners etc etc. i have seen something about test_write file being deleted solving the problem on a subreddit (for Radarr) but i can’t find that file.

Been trying for 2 days to solve this with no additional progress.

No clue what your permission issue is, but from the logs it looks like you’re using /Volumes/Drobo2/TV Shows/ as sonarr’s root folder as well as download location, unless I’m reading it wrong. You should keep those separate.

Small update – I was having the same problem with Radarr and Lidarr. Something i think that happened recently because i do recall automatically downloading the same show/movie like 4x probably because it couldn’t read my download folder to see it was complete and in my library.

I updated Mono to 3.0 and magically Radarr and Lidarr are working now and can read the directory. Sonarr, however, is still not working, and I’l tried to mirror the settings.

Any other suggestions?

Are you sure about this version? That’s ancient :wink:

(also, the version in your original post hits me now. 5.10 is also already a couple of years old, I think 5.12 is a safer bet, ideally 5.20)

Yes that was wrong.

Version

2.0.0.5344

Mono Version

6.8.0.123

I uninstalled and reinstalled Sonarr and still having the same issue

Not sure if the issue is still there with Mac OS changes to its security? Problem after upgrading to the new Apple MacOS Beta - Catalina

Awesome! Thank you! I searched but didn’t find this… Ultimately this solution worked for me (in case anyone stumbles upon this in the future)

JonSF’s recommendation seems to work.
If you would like to run the app without having to keep terminal open you can run the command as:
username@macname MacOS % cd /Applications/Sonarr.app/Contents/MacOS
username@macname MacOS % nohup ./Sonarr &
This will ensure the app runs in background, even after you “hangup”, without verbose terminal feedback.
You can then CTRL + C (hangup) or exit terminal, but the application will keep running.
If you create a bash script you can also do the same and just run the script behind the scenes and you never have to type full command again.

So the basic permissions problem is still there? I’ve been running normally (not via terminal) with sh wide open for way over a year now, and have been vaguely uncomfortable with that.

Just a clarifying question … The Root FOlders are where you want the TV episodes to reside when completed and moved? I think im having a similiar issue in another trhead. and have my Download Folder the same as the root folder