Import failed, path does not exist or is not accessible by Sonarr on Unraid 6.5


#1

Sonarr version (exact version): 0.2.0.1217
Mono version (if Sonarr is not running on Windows): 5.16.0.179 (tarball Thu Oct 4 10:29:10 UTC 2018)
OS: Unraid
Debug logs:
Description of issue:
Hi all,

I’ve read almost every post on this forum concerning this issue and tried several solutions, but no luck.

Here’s my setup:

  • Unraid
    /mnt/user/Media/Series/
    Container Path: /tv
    /mnt/disks/x.x.x.x_Media/Complete/Series/ (obviously I have my real ip address here for my file server on ubuntu)
    Container Path: /downloads
    puid: 99
    pgid: 100

I have created a user called sonarr on my ubuntu and gave them owner rights to the Series folder and assigned uid 99 and pgid 100 to it.

Unfortunately I still get the error “Import failed, path does not exist or is not accessible by Sonarr”.

Any help would be gratefully appreciated.

Cheers,

Pim


#2

That’s not a Sonarr version number, or at least not one from the last 5 years.

Debug logs are important, please upload them somewhere and link them here as requested.

Given docker is involved in some way? maybe? It’s either permissions or paths don’t align between containers, which you can either correct or use a Remote Path Mapping.


#4

sorry, just looked at it again and it says vs 2.0.0.5252

Hi Markus,

I do understand what you are saying, I just don’t know what to do :slight_smile:

I get that I need to give Sonarr access rights to that mounted folder, but I don’t know how.

Similar issue, where do I get the debug logs from? I can download the logs from sonarr but they don’t seem to be very helpful.

Cheers.

Pim


#5

Not sure what you’ll need to do for that, someone else may be able to weigh in.

That’s in the link I posted. Suggestions on where to upload them (then link here) is in the template from when you opened this issue.


#6

just to double check, you gave it rights to the downloads folder as well?
the docker container is configured to use that puid and pgid?

the other question is what paths does your download client use? eg your sonarr container can only see /tv and /downloads so if the download client is using a different path then sonarr wont be able to see it unless you either mount it as part of the container or map it via sonarr


#8

Hi Markus,

Please find the link to my log file here: log file

I had a quick look at it but I don’t think it will give you a lot of info.

Thx,

Pim

Hi Rhom,

I made some screenshots of the config, hopefully they help.

Thx,

Pim


#9

It doesn’t look like you have a volume mounted for /media/Media/Complete/Series/ so Sonarr can’t find it. You’ll need to mount one and unless Sonarr sees it exactly as reported by SAB it’ll need a Remote Path Mapping to translate the path SAB reports to one Sonarr can use to access it.


#10

Just so I understand correctly, I need to create a mapping to the complete/series folder in my unraid so it can get picked up by sonarr? At the moment I only have one to the /complete folder. I can see the series when I put in the mappings to the mounted drive in sonarr.


#11

You need Sonarr to have a volume mounted pointing to that folder, if you already have one pointed to the /complete folder (which I may have missed before) then you don’t need another, you just need to add a Remote Path Mapping to map the remote path to the local path (the container’s path).

Re-looking at your screenshot I think it’d be:

Local: /downloads
Remote: /media/Media/Complete/Series/

For Host make sure it matches what you used for the Host field in Sonarr’s SAB settings.


#12

I wrote a non specific wiki article about docker and this automation software that I think if you read, you’ll understand what is going on here.


#13

Great, I will give it a read later on. Cheers guys for all the help so far, greatly appreciated!


#14

btw, you dont actually have a /tv path its /Downloads/tv according to that screenshot (Host Path 3) so you might want to fix that - the description says /tv but thats just a description


#15

Ok, read the document, tried everything but no luck. Still getting this error. The weird thing is that I installed Handbrake in between my sabnzbd and sonarr and it was able to pick up my downloads without a problem.
Also when I process them manually everything works perfectly.

A lot of the recommendations made here, don’t apply to me as my Sabnzbd instance is installed on a different machine and not in a docker.

I keep on searching :slight_smile: