Hanna not updating Season 2 episode names

Sonarr version (exact version): 3.0.3.896
Mono version (if Sonarr is not running on Windows): 5.20.1.34
OS: Ubuntu 18.0.4 LTS
Description of issue:

Per title. Season 2 episode names are all still listed as TBA, but they are all named on TVDB (and looks like they have been for a while so should not be a cache issue). TVDB link is correct http://www.thetvdb.com/?tab=series&id=357690

Have tried a refresh, also removed and readded show, and restarted Sonarr.

Any ideas? I can just force the import and then cleanup and rename later, just curious why they won’t update if everything looks right.

20-7-2 17:59:28.1|Info|RefreshSeriesService|Updating Hanna
20-7-2 17:59:28.8|Info|RefreshEpisodeService|Starting episode info refresh for: [357690][Hanna]
20-7-2 17:59:28.9|Info|RefreshEpisodeService|Finished episode refresh for series: [357690][Hanna].
20-7-2 17:59:28.9|Info|DiskScanService|Scanning Hanna
20-7-2 17:59:28.9|Info|DiskScanService|Completed scanning disk for Hanna
20-7-2 17:59:29.0|Info|ExistingMetadataImporter|Found 0 existing metadata files
20-7-2 17:59:29.1|Info|ExistingSubtitleImporter|Found 0 existing subtitle files
20-7-2 17:59:29.1|Info|ExistingOtherExtraImporter|Found 0 existing other extra files
20-7-2 17:59:29.2|Info|ExistingExtraFileService|Found 0 extra files
1 Like

Finding the same thing even though the TVDB site has them named https://www.thetvdb.com/series/hanna/seasons/official/2

Opening the Series and clicking the refresh button doesn’t work for whatever reason and hasn’t worked to update the episode titles for a long time now. So long in fact I don’t ever remember it working. At least on Sonarr 2.0. You need to go to System > Tasks > Refresh Series. Click the Force Refresh (two arrows) button to force all series to refresh.

That did the trick, much appreciated! Albeit very cumbersome having to perform a full library scan just to hit a single show…

So here’s my next question: if the Refresh Series task is scheduled to run every 12 hours, and shows as having completed, why is it not updating the titles at these times but instead needs a forced run?

Those run the same task, the one from tasks just runs it for all series.

It’s more likely that when you refreshed a single series the data from TVDB was still cached (they have a 24 hour cache on their API).

Don’t know if this had any impact but they also changed the name of the series from Hanna to HANNA between seasons 1 and 2.

It shouldn’t have any impact. AFAIK it is linked to the series ID number, not the title.

Just wanted to add a final update: was able to confirm single series refresh still works. Had a different show that was not updating. Waited for TVDB to sync across, ran the single series update and it refreshed NP.

Also confirmed that the scheduled task update worked. Had another show that was pending an update and things resolved themselves overnight during one of the scheduled runs.