Windows Sonarr getting error Access to Path C:\ is denied

Sonarr version (3.0.4.982):
Windows 10 (2004):
20-10-14 14:29:10.5|Warn|ImportApprovedEpisodes|Couldn’t import episode C:\Users\Kayden\Downloads\complete\Long.Way.Up.S01E03.Southern.Patagonia.720p.ATVP.WEB-DL.DDP5.1.H.264-NTb\34a7c210b6984bbdb1e04724d658b71d.mkv

[v3.0.4.982] System.UnauthorizedAccessException: Access to the path ‘C:\Users\User’ is denied.:

Trying to manually import series because they downloaded and are in the complete folder however they will not move and every time I try to get them to move they just show as completed and the logs keep saying error due to drive permissions. How do I give Sonarr permission to that drive?:

Additional Information:
-I’ve tried updating the users permissions on the drive but that does not seem to have worked… Not sure how else to give Sonarr R/W permission on the C:/

If you’re running Sonarr via the Windows service (you can verify in System: Info), then you’ll either want to change the user or change how Sonarr is run because the default user for the service (Local Service) does not have access to user folders.

See the network path entry in the FAQ for more info.

So it is running as a service, however the user that it is setup to use is the same user that I have setup with admin rights and that downloaded the application… So there should not be a permissions error there I would think?
Aslo when trying to open the Sonarr appliction from the desktop shortcut I get an error that states “UnauthorizedAccessException: Access to the path C:\ProgramData\Sonarr\config.xml’ is denied.”
Ive gone into that file location and made sure that the Local user that I use for this server has full access but still no change? Any ideas why that would have changed?

Also I can open the Desktop application when right clicking and running as administrator… but when just trying to double click on it it gives the error I stated before?

It sounds like it shouldn’t but the error indicates otherwise.

That file should have full read/write access (all the files in there should so it can be run as a different user via the service or the executable).

Definitely something amiss with permissions, but I’m not sure what it could be.

Does importing work when running as administrator?

So yes I have tested that as well and it does work fine when running it as an admin… I have even compared the file settings with that of Radarr as far as file permissions and they are exactly the same however it still will not launch unless run as admin, where as Radarr will run no problem with just a double click from desktop.