Why is only the first episode not showing a runtime of 0?

Sonarr version (exact version):
Mono version (if Sonarr is not running on Windows):
OS: unRAID-Docker
Debug logs:
Description of issue: Why is only the first episode not showing a runtime of 0?
Starting from the second episode, all releases are showing a runtime of 0, while the runtime for this series is listed as 0 on TVDB.
The TVDB ID for this series is 434046.

There are a few things at play here:

  • v4 uses a per episode run time
  • If the runtime for the episode is 0 it will try to fall back to the series’ runtime
  • If the series runtime is 0 then Sonarr will use a runtime of 45 for any episode that aired within 24 hours of the first episode

Since only the first episode falls into the third case, it’s the only one that gets a run time, the correct runtime will need to be added for each episode in the series.

Thank you, I understand how this works now. I have another question to ask you. After searching the forum, I tried to modify the quality of webdl-1080p to (0/unlimited) to avoid this issue. However, this doesn’t seem to work in version 4.0, as the red exclamation mark similar to the one in the image still appears. Did I do something wrong with the method I tried?

No, nothing you did wrong, but if the runtime for the episode is 0 the release is rejected regardless of your size limits.

Thank you, I understand now. I believe this operating mechanism is quite important, as this issue may occur frequently due to problems with TVDB. I did not find any similar issues or solutions in the Sonarr/wiki. I suggest that the official documentation add a similar entry to explain this issue.
Thank you very much for your help.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.