Where does the source location come from

version: 2.0.0.5338
Mono Version: 6.8.0.96
OS: ubuntu 18.04.3

I was wondering where the source - system address that holds the downloaded files is set and held. Everytime I add a show it shows me the wrong one.

The wrong one looks like: /media/greg/name of show
The right one is: /media/greg/data/name of show
I just can’t figure out where in the world its coming from. I have checked settings, etc. to no avail.

Thank you…

It comes from your download client.

do you mean sabnzbdplus?

Yes, sabnzbdplus is a download client, but the same thing happens for every download client.

OP might mean the root folder, when adding a series, not an episode?

if they do then its under settings > media management, root folders (right down at the bottom)

the X on the end will let you delete any you dont want

Thank you for the reply…

It IS when I am adding a series. What is inserted, when adding a series is:
/media/greg/TV
What Should be inserted is:
/media/greg/data/TV

The last section under media managment looks like:

Permissions
Set Permissions
Yes No (set to NO)

File chmod mask
Folder chmod mask
chown User 0644
chown Group 0755

nothing about root folders

However, under Download Clients
the last part has: Remote Path Settings, ie:
The correct address, however, is correct:
Remote Path Mappings
Host Remote Path Local Path
127.0.0.1 /media/greg/data/TV/ /media/greg/data/TV/

I have two download clients: sabnzbdplus (ini) and transmission (json). Neither one seems to have this address in their options. I also checked their config files and nothing there either.

I have also searched the entire disk for /media/greg/TV and cannot find it in any files (must have missed something - mysteries abound?)

One last thing. The last series I added inserted the bad address. Then it downloaded episodes. I still got the error but sonarr created the holding folder in the right place and then transferred the downloads correctly. Then it listed the same error! This is getting pretty strange.

Its really pretty simple to fix. All I have to do is to goto series editor search for /greg/TV and fix it. At the bottom of series editor, however there is a place to enter the root folder. I think I will put in /media/greg/data/TV/ and see what happens. Just tried that. It only works for individual series. However, when messing around I choose a series and clicked on it. That released the setting for the series. Then I clicked on the root folder part and up popped, in choices, the good and the bad.

Thoughts?

Permissions in Sonarr are done after importing. Root folder permissions need to be set outside of Sonarr.

Not sure what you’re trying to do, but remapping to a path to the same path won’t do anything.

That’s impossible. Sonarr will only import to the folder set for the series.

If you have a bad root folder remove it from Add Series: Import existing and add the correct path.