V3 / qBit 4.16 and seed ratio/time

Sonarr version (exact version): 3.0.1.520
Mono version (if Sonarr is not running on Windows): Mono JIT compiler version 5.20.1 (makepkg/886c4901747 Wed Apr 17 15:49:14 UTC 2019)
OS: ArchLinux
Debug logs:

(N) 2019-06-17T20:18:03 - 'battlebots.2015.s04e02.1080p.web.x264-tbs.mkv' reached the maximum seeding time you set. Removed.
(N) 2019-06-17T20:18:03 - 'battlebots.2015.s04e02.1080p.web.x264-tbs.mkv' was removed from the transfer list.
(N) 2019-06-17T20:51:53 - 'Marvels.Agents.of.S.H.I.E.L.D.S06E05.720p.HDTV.x264-AVS.mkv' reached the maximum seeding time you set. Removed.
(N) 2019-06-17T20:51:53 - 'Marvels.Agents.of.S.H.I.E.L.D.S06E05.720p.HDTV.x264-AVS.mkv' was removed from the transfer list.

(Make sure debug logging is enabled in settings and post the full log to hastebin/pastebin/dropbox/google drive or something similar, do not post them directly here. Post in .txt not .doc, .rtf or some other formatted document)
Description of issue:

I have seed time ratio set for BTN as an example and I can see it being passed from Sonarr but I am not sure if it’s passing the right API call to delete and remove it as I am seeing quite a lot of orphans:

I think it’s doing delete instead of deletePerm:

This is something that may have changed in their API changes, since we send the deleteFiles param with the request, instead of using deletePerm.

Sonarr isn’t doing anything, that’s qbit’s log. Your Qbit configured to Remove torrents rather than pause them, so Sonarr never sees them in their finished state.

Also, you linked to the old qbit 3.x api documentation. :smile:

Sorry as I did link the wrong thing as that was my mistake.

I’m not following though as I have BTN configured for seed time. I can see when Sonarr passes the seed time, but my guess was it isn’t passing whatever the API command is to delete the files as well.

I shared the qbit log on purpose as I can see the torrent is being removed but not deleted, which lead me to my question in regards to the API command coming over.

I can pump up to trace to capture the API command if that helps, but definitely they are being orphaned and I’m not sure why as I have no qBit items configured as it all comes over from Sonarr with the seed time.

You don’t understand, qbit has a global setting that determines what to do with items that finished seeding, it can be set to Remove or Pause. You’ve got it set to Remove, instead of Pause.

“reached the maximum seeding time you set. Removed.” in the qbit log means that Qbit is deleting the download, NOT Sonarr. So Sonarr is never able to tell qbit to delete it including files.

Any idea what that global setting is ?

I have nothing turned on in qBit from what I can tell:

image

Change the ‘Remove them’ to Pause. You can toggle one of the checkboxes on temporarily to do it.

So for my understanding on the flow, Sonarr is passing the seed ratio time to qBit, which I can see in the ETA and once the seed time hits, Sonarr than passes a API hit via the deleteFiles which is the process that actually cleans it up?

I had incorrect thought it was all one API hit in the beginning, which I can see now was incorrect.

I toggled it on and changed to pause and toggled it back off. Much thanks for your help.

That’s exactly it.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.