Upgrade from v2 to v3 epic fail TypeLoadException

Win 10 Pro 1909 128353.720
Trying to open sonarr after upgrade to v3 leads to epic fail TypeLoadException


Absolutly no clue. :wink:
I have tried new installation, delete folders, allways the same outcome.

Thx in advance and Regards

20-4-2 12:19:37.5|Info|Bootstrap|Starting Sonarr - C:\ProgramData\NzbDrone\bin\NzbDrone.exe - Version

That’s the only executable I see for Sonarr and that’s the v2 executable.

At this point I’d recommend grabbing a backup of the configuration, removing Sonarr/NzbDrone from Programs & Features then install Sonarr again. Start it up and restore the backup if it’s not migrated automatically (as long as you don’t remove C:\ProgramData\NzbDrone manually it should migrate).

Thx; Marcus. I did that allready. I removed Sonarr2 and I tried removing Sonarr2 and removing folders in program data.
I try to install Sonarr 3 => epic fail, therefore I have only v2 logs. I can’t import my backup, with the ongoing epic fails.
Somethings hiding I have to delete?

The Sonarr service does not start. When I start it manually it is immediately terminated.

v2 logs won’t help. v3 has everything in C:\ProgramData\Sonarr, if it’s starting then failing at all then there will be logs there.

Try removing the bin folder for v3 and installing again.

Ups, did not know.

v3 logs

NzbDrone.Api.dll shouldn’t exist in that folder. Uninstall Sonarr, remove that bin folder and re-install.

Sorry, I have to ask. To which bin Folder are you referring to?


Thx Markus, that did the trick. Working now. :wink:

Well, I have another issue.
The files are downloaded but never imported.


  • No files found are eligible for import in D:\Newsbin\SONARR\the.daily.show.2020.04.02.bill.gates.1080p.web.x264-trump\

File is just waiting for import

D:\Newsbin\SONARR\the.daily.show.2020.04.02.bill.gates.1080p.web.x264-trump. Ensure the path exists and the user running Sonarr has the correct permissions to access this file/folder

What’s wrong? How to change permissions? It worked on v2.
Whole fresh log

Those aren’t debug logs and don’t show an import being attempted. And ControlC is overlaying content because I have an adblocker, better to use something that doesn’t do that.

Sorry, log was over 512kb limit on pastebin.
I changed my previous unrar folder in newsbin to another location and sonarr started importing files from there.
Guess sonarr had permission for that location. It works now.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.