Unable to open database file (new install / update)

Sonarr version (exact version): 3.0.5.1144
Mono version (if Sonarr is not running on Windows):
OS: Windows 10

I do have massive problems with Sonarr3 and cant get it running.

  • The updated from the old Sonarr failed (cant remember the excact message) and i cant import the backup of the old (nzbdrone) file to the new sonarr (simply dosnt recognize it)
  • After fresh install and importing of series or adding one, it appears in the series menue, but when i try to search for a new episode it fails: Episode search failed: unable to open database file
  • I had several problems when mass importing my old drive with the series, that the import failed, afterwards the app didnt load at all (same error, unable to open database file).

So far i reinstalled, tried to manually give “everyone” full access to the directory.

Im out of any ideas … anyone with an idea?

Debug logs:
Message
Episode search failed: unable to open database file
unable to open database file: unable to open database file
unable to open database file
Exception
System.Data.SQLite.SQLiteException (0x80004005): unable to open database file
unable to open database file
bei System.Data.SQLite.SQLite3.Reset(SQLiteStatement stmt)
bei System.Data.SQLite.SQLite3.Step(SQLiteStatement stmt)
bei System.Data.SQLite.SQLiteDataReader.NextResult()
bei System.Data.SQLite.SQLiteDataReader…ctor(SQLiteCommand cmd, CommandBehavior behave)
bei System.Data.SQLite.SQLiteCommand.ExecuteReader(CommandBehavior behavior)
bei System.Data.SQLite.SQLiteCommand.ExecuteNonQuery(CommandBehavior behavior)
bei System.Data.SQLite.SQLiteCommand.ExecuteNonQuery()
bei Marr.Data.QGen.UpdateQueryBuilder1.Execute() in M:\BuildAgent\work\63739567f01dbcc2\src\Marr.Data\QGen\UpdateQueryBuilder.cs:Zeile 156. bei Marr.Data.DataMapper.Update[T](T entity, Expression1 filter) in M:\BuildAgent\work\63739567f01dbcc2\src\Marr.Data\DataMapper.cs:Zeile 674.
bei NzbDrone.Core.Datastore.BasicRepository1.UpdateMany(IList1 models) in M:\BuildAgent\work\63739567f01dbcc2\src\NzbDrone.Core\Datastore\BasicRepository.cs:Zeile 175.
bei NzbDrone.Core.Tv.EpisodeService.UpdateEpisodes(List1 episodes) in M:\BuildAgent\work\63739567f01dbcc2\src\NzbDrone.Core\Tv\EpisodeService.cs:Zeile 181. bei NzbDrone.Core.IndexerSearch.NzbSearchService.Dispatch(Func2 searchAction, SearchCriteriaBase criteriaBase) in M:\BuildAgent\work\63739567f01dbcc2\src\NzbDrone.Core\IndexerSearch\NzbSearchService.cs:Zeile 518.
bei NzbDrone.Core.IndexerSearch.NzbSearchService.SearchSingle(Series series, Episode episode, Boolean monitoredOnly, Boolean userInvokedSearch, Boolean interactiveSearch) in M:\BuildAgent\work\63739567f01dbcc2\src\NzbDrone.Core\IndexerSearch\NzbSearchService.cs:Zeile 302.
bei NzbDrone.Core.IndexerSearch.NzbSearchService.EpisodeSearch(Episode episode, Boolean userInvokedSearch, Boolean interactiveSearch) in M:\BuildAgent\work\63739567f01dbcc2\src\NzbDrone.Core\IndexerSearch\NzbSearchService.cs:Zeile 93.
bei NzbDrone.Core.IndexerSearch.NzbSearchService.EpisodeSearch(Int32 episodeId, Boolean userInvokedSearch, Boolean interactiveSearch) in M:\BuildAgent\work\63739567f01dbcc2\src\NzbDrone.Core\IndexerSearch\NzbSearchService.cs:Zeile 56.
bei Sonarr.Api.V3.Indexers.ReleaseModule.GetEpisodeReleases(Int32 episodeId) in M:\BuildAgent\work\63739567f01dbcc2\src\Sonarr.Api.V3\Indexers\ReleaseModule.cs:Zeile 159.

It looks like the DB is corrupt, restoring an older backup might work, depending on when the corruption started.

I installed new several times before finding the following out:

  • I just install it, change the settings: all works
  • I backup the fresh database: all works
  • I add a tv series OR i import one: app works bit i cant search (the above error message) - dosnt matter if i reinstall.

NOW: im not sure yet if this has something to do with it

  • My current media PC sits in another room, i only access it remote (TeamViewer or RemoteDesktop), - thats what i did when updating (which failed) ior right now.
  • I installed sonarr on my main PC - works without a flaw

Could this have something to do with it? Installing / running the software as remote user somehow dosnt work? I have no keyboard for the other pc, nor a monitor atm, but maybe … ?

sounds like the user sonarr is running as (if service) or under (if tray app) cannot access it’s own database… that’ll be a basic permissions issue

But i already running it as Administrator - i dont get it.

It’s just basic file permissions

Or a corrupt DB, you don’t have your storage on a network mount right? SQLLite hates being in network storage and completely falls apart

It is still running as some user and can’t access its own directory…which it can be default which means either you changed something or something else on your system changed something

Are you running as a service or tray app?

I tried all three - run as a service, run as the logged in user and run as administrator (tray). No change

I now removed Sonarr complete from my computer, logged on locally and directly and reinstalled it (deleted all which wasnt removed by the deinstalled manually).

It isnt even starting up now:

Exception: unable to open database file WhileProcessing: “CREATE UNIQUE INDEX “UC_version” ON “VersionInfo” (“Version” ASC)”

Anyone with an idea?^

EDIT: For now i removed SONARR 3 from the System and again running SONARR 2 without any problems :frowning: ) - really hoping someone can help me out

No, all is local on the media computer.