Unable to connect to SABnzbd V.3.0.6

**Sonarr version (exact version) 3.0.6.1265
**Mono version (if Sonarr is not running on Windows)5.20.1.34
OS: Synology Version: 6.2.4-25556 Update 2
Debug logs:

Its not a firewall issue
Description of issue: can connect to SABnzb that is running on the same local unit
I have SSL enabled on the SABNzd and a different port set the correct port on sonarr still no go
diable the certification validation for local address, still no go
Disabled the SSL on the SABnzbd and on sonarr, no go
still keep getting this error
Tried 127.0.0.1, tried my Synology IP

why are you using SSL to connect to localhost…that is illogical and makes no sense. in fact it implies you believe your NAS is compromised and insecure.

Nothing is running on https localhost 9091

as far as im aware the only way to run sab on dsm is via docker - are you doing this? if so what parameters do you use to setup the container?

and are you using sonarr in docker as well or is it the synocommunity package?

how? what url are you using that works? does the web browser show it as actually SSLd properly? (padlock icon with no certificate issues)

sabnzbs default https port is 9090, not 9091, you might want to try that instead - you can always confirm what port its actually using in sab itself.

in sonarr can you try setting it to port 8080 with SSL disabled

Because its running on the Synology you can choose what port you want to use, I choose 9091

Dont use docker, running SABnzbd on sonrarr on the DSM itself
I changed the SABnzbd port to 9091

So managed to solve the issue.
I created to new forwarding rules on my firewall to the local IP for ports 8989 and 9898
In the setting of sonarr instead of the local host I put my Synology IP and this time it worked

Thank you everyone for the help