Unable to connect to NzbGet with Sonarr in Docket container on Synology

Sonarr version (exact version): Sonarr Ver.
Mono version (if Sonarr is not running on Windows): Synology w/ Docker
((Debug logs)) (posted to hastebin or similar):
http://imgur.com/uvfZWAm screenshot of error

Description of issue:

Hi all,

Running Sonarr in a Docker container on Synology DSM. nzbget is also running in a Docker container on the Synology. Trying to get Sonarr to talk to n zbget using the default settings, localhost:6789 however get
Test was aborted due to an error: Unable to connect to NzbGet. Error: ConnectFailure (Connection refused)

See pastebin logs. I get zero logs on nzbget, the connection doesn’t even get there, it fails at Sonarr.

I’m fairly new to containers and think I might be overlooking something, do I need to allow the container to do something to allow this connection on port 6789 to work? Correct username and password and config is given.

Also note nzbget is listening on (all IPs) and can snatch nzbs successfully etc… tried getting Sonarr to use and also the local 192.x.x.x IP, same error.

The connection is getting refused, either a firewall is blocking it or its not listening on that port. Beyond that I’m not sure where to suggest starting your troubleshooting.

Posted on reddit and someone provided the solution!

Edit Sonarr container “links” and add nzbget as a linked container. Use the alias that you set for the linked container to resolve nzbget, this will allow Sonarr to talk to the nzbget container. Using “localhost” or inside a container refers to the environment inside the container, not the NAS or server’s environment that it’s running on. Unless the processes were running inside one container, this won’t work and you’ll have to link them for them to be able to talk to each other between different containers.

Pictures here on how to do this: http://imgur.com/a/37cTA

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.