Unable to access folders: Sonarr on Debian VM

Hi guys,

I tried to search the forum but didn’t find anything helpful so far so I’m trying here. If already explained somewhere don’t hesitate to point me there!
I’m trying to run sonarr on my debian virtual machine where I have my plex server

  • When I try to add a folder in Settings/Media Management/ Root Folders/ Add Root Folder I can select the hard drive I want but I don’t see sub folders, and when I click OK nothing happens
  • When I try to add a new TV show I get “Invalid Path” even if I browse and select the hard drive I want
    I can see my 2 hard drives so that’s already something
    I imagine they don’t have the correct access so I tried Settings/Media Management/Permissions --> chmod Folder 777 and chown group I typed the name of the group

2 questions:

  • how do I give access to sonarr to read/write the folders from the debian interface ? (sorry I’m a noob on debian interface I just set up the plex server following a tutorial)
  • where can I check the user and group that I set up during installation of sonarr ? I’m pretty sure I know them but now that it’s not working I have a doubt and want to double check

Thanks a lot!

Version 3.0.4.1021
Package Version 3.0.4 by Team Sonarr
Mono Version 5.18.0.240
AppData directory /var/lib/sonarr
Startup directory /usr/lib/sonarr/bin
Mode Console