[Ubuntu] Folder is not writable by user


#1

Sonarr version (exact version): 2.0.0.5252
Mono version (if Sonarr is not running on Windows): 4.6.2
OS: Ubuntu 18.04.1
Debug logs: NzbDroneErrorPipeline|Invalid request Validation failed: – Folder is not writable by user xxxxx
Description of issue:

Im getting this error when trying to import my existing TV Shows folder from my Cloud storage server mounted using rclone in ubuntu 18.04.1 running Sonarr and Plex.

I’ve made sure my mount is mounted with uid 1000 and gid 1000 and that sonarr is running as the same. and the user has rw access to the /mnt/storage/tvshows folder as well as /opt/NzbDrone

Sonarr logs say “NzbDroneErrorPipeline|Invalid request Validation failed: – Folder is not writable by user xxxxx”
and nothing else.

I’ve searched and tried 10’s of different solutions from different threads and none of them have worked for me.

what am I doing wrong?

SABNzbd is set up and works fine with reading/writing to the cloud vfs… i dont see why sonarr is having these issues.

I am able to create folders and files in these directories but sonnar continues to not have to right permissions…


#2

Still having this issue. Is anyone able to help me?

Thanks.


#3

chmod 0777 /mnt/storage/tvshows

if you want more security on that folder. Add Sonarr to the group that owns the folder.

chmod 0775 /mnt/storage/tvshows