Tried everything but can't resolve - Import failed, path does not exist or is not accessible by Sonarr

Sonarr version 2.0.0.5337:
Mono version (if Sonarr is not running on Windows):
OS Windows 10 Home:
Debug logs https://pastebin.com/jtEF8aHj:
Sonarr is downloading through qBittorrent but can’t import the downloaded files:

Additional Information:
I’m new to Sonarr and have spent hours trying to understand why this isn’t working. I’ve read lots of posts and tried all the things they’ve mentioned but I’m struggling.

I have tried running NzbDrone service as different users/admin but it doesn’t seem to make any difference. I have disabled it as a service and moved it to the Startup Folder but it makes no difference.

I’m downloading to an external hard drive (E:) and have tried setting various different folders for the completed downloads and the sorted files without any result. I’ve tried using UNC paths but I don’t think I’m understanding how that works.

Any help would be immensely appreciated as this is frying my brain right now.

Still not resolved - Sonarr is doing everything it should except for importing automatically. For every download I have to import manually.

Updated log: https://pastebin.com/1Z1PEsqS

I was using qbitorrent when I had the same issue. Switched to another client and it worked. About pulled my hair out over this trying to give sonarr access and other service methods. Came down to the client I was using.

I’d prefer to use pBittorrent over the other clients it supports but until I pin down the issue, I am using Deluge. Keep in mind I tried Utorrent and Trasmission too. So it was indeed qBittorrent causing my issue. Give it a go and let me know if that fixes it for you.

1 Like

Does this folder actually exist?

19-7-19 11:17:52.7|Error|DownloadedEpisodesImportService|Import failed, path does not exist or is not accessible by Sonarr: E:\Downloads\Completed\TV\American.Dad.S15E12.720p.WEBRip.x264-TBS[rarbg]

Or is there only a file there?

QBit has an option to create folders for torrents, which needs to be enabled, beyond that check the FAQ in regards to network drives (if it’s a network drive), otherwise make sure the user running Sonarr has access (if you’re running Sonarr as a Windows service try stopping it and running it directly).

2 Likes

It was the folder. I was reading the log as pointing to a file not looking for a folder. Changed that one setting in qBittorrent and everything is now working.

Thank you!

1 Like

Do you recall if that’s a setting you disabled before? Just wondering if the default is incompatible or it was changed and subsequently broke Sonarr.

What setting did you change exaclty?

Options–>Downloads–>Create subfolder for torrents with multiple files

It may mean an occasional one still doesn’t work if there isn’t more than one file in a torrent

1 Like

Options–>Downloads–>Create subfolder for torrents with multiple files

I believe it must be disabled by default because I’ve never changed it. Any torrents with a single file will still fail, if it’s an issue I’ll have to switch to a different client that handles it better.