Torrent blackhole - folder does not exist


#1

Since updating to the latest sonarr 3 beta, my utorrent download client is reporting ‘folder does not exist’ although it does. Bug.


#2

Nothing changed in v3 for blackhole, sounds like permissions. Not bug.


#3

In this case, the functionality worked as expected in v2 prior to updating to v3. Also, I’m able to browse to the appropriate folder structure within Windows, outside of Sonarr without issue. It’s only within the Sonarr setup, when attempting to browse the same folder structure that they’re not visible. For example, if I browse to c:\folders\torrent\tv_torrents within Windows OS, no issue. But when browsing within Sonarr, am able to see contents of C:\folders but once I browse to \torrent sub folder, Sonarr shows no sub folder structure within it. Thanks.


#4

what account are you running the sonarr executable as? your own, the system, another service account?

right click on c:\folders\torrent\tv_torrents select properties > security, is that account listed, and what permissions does it have?


#6

Hi rhom, thanks for your response. I am running under my system admin account when running the sonarr executable. Also when I right click on the folder above, the security does reflect the same admin account for all levels (sub-folders) of the folder structure. This system admin account has all security permissions except for FULL CONTROL. These permissions are identical to v2.

OK. I’ve since followed these instructions to change from a local service account to the same system admin account (for the Sonarr service) that has access to the specific folders, and it worked successfully. Thanks for your guidance.