'The application Sonarr can't be opened. Mac OS Catalina v10.15

Sonarr version (exact version): Latest v2. & v3 Beta downloads straight from How to uninstall sonarr on MAC
Mono version (if Sonarr is not running on Windows): 6.4.0.198
OS: Mac OS Catalina 10.15
Debug logs:
Description of issue:

Hi guys,

Apologies in advance if I’m a little vague and lacking technical terms throughout my description of issues here, I’ve spent hours reading through posts and doing my best to grasp the terminology but am openly in a little over my head!

Issue in a nutshell:

  • Upgraded my Mac mini to Catalina OS, which I’ve used for a few years as a data hub at home without any issue. SABnzbd / Sonarr / Plex. Since the upgrade to Catalina, encountered issues with my external HD, which eventually led me to replacing external HD. Encountered issues listing the new HD as the path folder, and read an article suggesting uninstall/reinstall Sonarr as a potential easy fix. Followed this article to do so: How to uninstall sonarr on MAC

  • Downloaded Sonarr after following uninstall instructions, but faced ‘The application Sonarr can’t be opened’. (have tried v2 and v3)

  • Most articles I read refer back to the config/NZBDrone folder - this is missing for me. I don’t have any reference to NzbDrone on my Mac mini at all, and therefore can’t track down log files etc which I see referenced in a lot of trouble shooting pages. No backup etc for these folders either (likely cleared in one of my many hopeless attempts to get it working again).

Any basic trouble shooting steps or links to same issue would be greatly appreciated.

Thanks in advance!

Justin

1 Like

I had the same issue; but the fix is pretty simple.

It turns out for whatever reason the Sonarr bootstrap script wasn’t actually marked as executable when the app bundle was built. Assuming the Sonarr app you downloaded has been moved to the Applications folder, run the line:

chmod +x /Applications/Sonarr.app/Contents/MacOS/Sonarr
5 Likes

Oh wow - you’re right that fixed it instantly! Thanks so much for your help :slight_smile:

Thank you, thank you, thank you. This fixed my problem and I have been reading forums for days on end. Thank you.

Thanks man been racking my brains for days it worked right away

open Terminal and run command which ever one is relevant to the app your getting to run in OS Catalina Then your App will open up and run…

chmod +x /Applications/Radarr.app/Contents/MacOS/Radarr

chmod +x /Applications/Sonarr.app/Contents/MacOS/Sonarr

It has not worked for me, I no longer have the message that “I cannot open the app”, but it is frozen and although it appears as Sonarr is open it but does not open anything and the only way out is to force the exit.

I’m having the exact same problem as you did, ezeqpo. The error message that “I cannot open the app” has now gone but when I double-click the application nothing happens. It appears to be running in Activity Monitor but that’s it. Nothing else. Can’t connect to that 8989 web address in Safari either. Did you ever manage to figure it out?

1 Like

What OS do you use? I use the latest version of Mac Os Catalina.
The truth is that I don’t know what else to do to make it work.

Yeah, I’m using Catalina too. I have no idea either. This may be the most difficulty I’ve had installing an app ever!

1 Like

I think the same. If I find the solution to this I will notify you.

I’m having the same problem. The Application 'Sonarr" cannot be opened. I have reinstalled mono and sonarr, with the same result.

Trying to open Sonarr from a terminal window gives:

base) Legolas:Applications michael$ open Sonarr.app
LSOpenURLsWithRole() failed with error -10810 for the file /Applications/Sonarr.app.

This fixed my problem. Sonarr is running again …

cd /Applications/Radarr.app/Contents/MacOS
chmod +x Sonarr
./Sonarr

I still can’t get it working, but then I don’t have Radarr. Do I need that?

This does not work for me, even after I made it executable I still get “You can’t open the application “Sonarr” because it is not responding.”

❯ ls -la /Applications/Sonarr.app/Contents/MacOS/Sonarr
-rwxr-xr-x 1 stephen 2138 Feb 19 20:00 Sonarr*

But if I run the script directly everything starts up fine

[Info] Bootstrap: Starting Sonarr - /Applications/Sonarr.app/Contents/MacOS/Sonarr.exe - Version 3.0.3.698
[Info] Router: Application mode: Interactive
[Info] MigrationLogger: *** Migrating data source=/Users/stephen/.config/Sonarr/sonarr.db;cache size=-10000;datetimekind=Utc;journal mode=Truncate;pooling=True;version=3;Full FSync=True ***
[Info] MigrationLogger: *** Migrating data source=/Users/stephen/.config/Sonarr/logs.db;cache size=-10000;datetimekind=Utc;journal mode=Truncate;pooling=True;version=3;Full FSync=True ***
[Info] OwinHostController: Listening on the following URLs:
[Info] OwinHostController:   http://*:8989/
[Info] SonarrBootstrapper: Starting Web Server

I’ve also deleted ~/.config/Sonarr/logs.db and ~/.config/Sonarr/logs.db-journal as mentioned elsewhere but it makes no difference, similar with ~/.config/Sonarr/sonarr.pid

Any other ideas?

Same situation here. Keeping this thread alive.

1 Like

Ok folks, here’s how I fixed it. The problem was a corruption in the NzbDrone sqlite database, thankfully the system automatically does backups.

Go to:

cd /Applications/Sadarr.app/Contents/MacOS
chmod +x Sonarr
./Sonarr

When you execute Sonnar (last line above) you will see a huge red error message with the solution, that is to restore the corrupted db from backups. The backups are at:

/Users/{username}/.config/NzbDrone/Backups/

I chose the scheduled folder and extracted the latest nzbdrone backup in there, in my case it was nzbdrone_backup_2020.02.29_22.15.01.zip. The files that it gives you, you replace them in:

/Applications/Sadarr.app/Contents/MacOS

And start the app again like a boss :sunglasses:

K.

My problem is nearly identical to this one, and suspect the solution would be similar but not sure how to test. I am running Sonarr through Docker. Getting the same errors and rejected imports.

So, no tangible Sonarr macOS app to move to the applications directory…yet suspect my problems are probably the same type.

Anyone w/ideas around how this would work through Docker?
Docker is, btw, in the Applications folder (main admin apps, not user)

I believe the only relation this issue has with yours is you’re using macOS. This thread is about Sonarr running through mono directly on macOS, not through docker and you have an existing thread open on it.