Spaces in filenames -> sonarr cant read them

Sonarr version (2.0.0.5338):
Mono version (5.18.0.240):
OS: Synology 6.22
Debug logs:
Description of issue:

I think spaces (in the naming: /volume1/HTPC I/series… so a space @HTPC I) are leading Sonarr to not be able to read the file names (same as issue in linux apparently, though I have no Linux experience)

Have been using Sonarr for a long while. the issue I see now has not popped up yet, so also don’t know what happend. as of this week I have an extra synology system (#2) and was setting that up, mounted folder on that one to copy from one to the other. tried to set up sonarr on that one. Everything worked - install, setup of sonarr, using the backup file from the old synology (#1), and validated that all settings returned including all the series. However, when trying to change a file the list of series does not get populated anymore…

what happened, or even better, what can I do


And now Sonarr says it is missing the root folder

strangely enough I have two synology systems (setting over from one to the other so trying to replicate them) #1 does not have the problem, #2 does

#1 is also not able to find the series anymore in the manual update as the picture in the previous post, but does not have the warning below - update, now also the other server has the same root issue. possibly due to folders which are temporarily mounted? will check tomorrow, when copy over is completed
#2 does have the warning and cant find any series manually anymore

But these are the folders in synology:

synology%20folders

Spaces aren’t a problem and very common, sounds like an issue with permissions.

so have tried all settings to get this to work. any pointers? It now is on both systems. I have two folders HTPC I and HTPC II. the second one works, the first one not. Plex is not able to read the folder, Midnight commander and Sonarr (at least those I have tried. File explorer is able to read everything in the folders. If I check through MC for the permissions it is rwx rwx r for owner admin and group users (at least for server #1)

due to the mucking around I have now also lost access to the HTPC II… What permissions and how to set those should I do?

Ok, making progress. so apparently the group needs to be nzbdrone (or at least with that both sonarr and plex work), the owner needs to be sc-nzbdrone, and the persmission: rwx r-x r-x. Now How to set that for the whole folder and child folders at once?

Not sure if you can do it in the UI, but via command line -R is recursive (chmod -R owner:group for example).

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.