Sonarr V3: Plex Notification Issue with SSL


#1

Trying to add notification to plex media server which has ssl enabled using self signed certificates. When i test the connection the following error is seen in the sonarr logs

Certificate validation for https://192.168.1.21:32400/library/sections?X-Plex-Client-Identifier=Identifier&X-Plex-Product=Sonarr&X-Plex-Platform=Windows&X-Plex-Platform-Version=7&X-Plex-Device-Name=Sonarr&X-Plex-Version=3.0.1.490&X-Plex-Token=tokenfailed. RemoteCertificateChainErrors

Do i need to do specific setup to get ssl to work when talking to plex? I have the same notification enabled in Radarr and i dont recall doing anything specific to get ssl to work.
Version

3.0.1.490

Package Version

3.0.1.490-ls71 by linuxserver.io

Mono Version

5.20.1.19


#2

Either use the FQDN that matches the certificate or disable certificate validation for local addresses.


#3

Thanks for reply. Ya looks like fqdn wont be an option as the certificate that is generated by plex and the CN has *.some-chars.plex.direct.

I changed the network -> secure connections to preffered and now i am able to set this witthout ssl and get it to work.