Sonarr Unable to Create Hardlinks (non docker)

Sonarr version (exact version):
Mono version (if Sonarr is not running on Windows):
OS: Debian 12
Debug logs:

Description of issue: I noticed that Sonarr was taking a long time to process a manual import and decided to look into why. After doing so, I stumbled upon the above error. Since I am able to create symbolic links manually any idea why Sonarr is unable to?

Troubleshooting steps:

  • Created the hard link manually (successful)
  • Tried a different series in the anime folder (same error)
  • Verified using inodes that there was no hard link (no hardlink)

Directory Structure:
├─ Downloads/
├─ Movies/
├─ Shows/
├─ Anime/

The solution was that created torrent files had permissions set so that qBittorrent was the owner and public didn’t have permissions. The issue was resolved by running an ‘external program’ in Settings->Downloads->‘Run External Program’ of qBittorrent to set permissions to chmod -R 777 %F giving my Sonarr instance read, write, and execute permission. I understand this isn’t the most secure option however, it is the only one that has worked so far.

Would changing the user qBit is running as, so it matches that of Sonarr, not be a better solution?

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.