Sonarr Synology not copying shows into the right folder

Sonarr version (exact version):
Mono version (if Sonarr is not running on Windows): Synology Docker
OS: Docker on Synology
Debug logs: No debugging logs
Description of issue:
Hi all,
I updated Sonarr 2 to Sonarr 3, and since then my shows are no longer copied into the /shows directory. I see them all in the /download folder but that’s where they remain, there is also no renaming.
Are there any additional settings that I am missing?

The root folders are configured as in the image above, yet they don’t copy into the /shows folder.
These are my folders on the NAS: Screen Shot 2021-05-26 at 21.31.32
Thank you all for your help:)

  1. poor paths (unless you hate to your hard drives and for torrents enjoy using double space)

  2. likely caused by poor paths and ownership/ permissions

Glad to see you did 0 troubleshooting since you have no logs attached.

I don’t know where to find the logs for Sonarr 3.0. Did a few Google searches and tried their recommendations. Permissions should be ok, it worked with the exactly same permissions before.

I will try to find the logs and post them.

Update: I found them under systems. Was looking under settings for an eternity, here is the newest log file:

It is a path problem and it says the path does not exist, but it complains about the /downloads folder (files are being downloaded) But I would assume that’s transmission (torrent client) that handles the download location. Does that mean it’s not a problem copying to the new destination, but reading from the /download folder?

The forum post template has a link to the logs.

Those are info logs which are fairly useless for debugging.

Your issue is 100% a common issue due to poor configurations.

See the previously provided troubleshooting and docker links to fix your stuff up.

it seems odd if you went from 2 to 3, with both already in docker, and this happened. this is typically something you “screw up” when first setting it up.

essentially /downloads exists in the transmission container but it doesnt exist in the sonarr container so when transmission tells sonarr the file is ready and to pick it up from /downloads/job/filename.mkv sonarr cant find it because that path does not exist, for sonarr.

you could add a remote path mapping but then hardlinks wont work so you really want to fix this properly to allow that that work.

with your existing data path setup you would have /media setup as the only docker (data) volume in both containers. youd have /config as well but thats not important for this.

once the /media volume is setup you change transmissions save folder from /downloads/... to /media/downloads/... and change the root path in sonarr from /shows/... to /media/shows/..., as well as updating the root path for every show you already have as well.

that way when transmission tells sonarr the file is ready and to pick it up from /media/downloads/job/filename.mkv then sonarr wont have any issues finding it and importing it. presuming the permissions are setup properly.

You were right it was something I setup wrong. The issue is resolved. I copy pasted it and setup 3.0 as a new installation. The issue was the OS autocorrect changed the directory name from /downloads to /download. It’s very unexpected behavior, no wonder I didn’t find it.
Thank you so much for your help.

Those paths are not great…I mean unless you like double space for seeds and slow I/O (HDD) intensive copy +deletes

See the docker and trash guides posted earlier

You are right. I keep having to delete them. I’ll change that too :slight_smile: thank you for the tip.

Hi, I finally installed it according to the Trash Guide, thank you for the link again.
Now all the ARRs are running in docker. My problem now is, that I do not know how to access their web interfaces. Before I had to enter the IP:PortNo. Now that does not work anymore. Is there another way to access them?

part of each containers setup is which ports to publish, ie how to map a container port back up to a host port.

eg; my sonarr container is setup with --publish 32800:8989 so i can access it via that 32800 nas/host port

i also use dsm > control panel > application portal > reverse proxy to map it from http://sonarr.home to http://localhost:32800, so the url is easier and you dont have to remember which port is which. same for all the other *arr containers. you would also need add “local” (*.home domain for me) a entries for each container into dns manager, or bind, or whatever dns server you use, if you want that to work.

Thanks, I learned something new. It worked well. Also thanks for the application portal mapping, much easier:)

The mapping doesn’t work, I assume it’s a wrong port setting

Now I have another weird problem. I tested a download, it said in Radarr that the file is downloading. Then I went to the torrent client (transmission) and it was downloaded completely, but there is no file at all in neither folder.
These are the volumes that the torrent client as access to

When I go back to Radarr is says still downloading the path in Radarr is /data/media/movies/
When I select the files tab in Radarr is says no movie files to manage.
Also in Radarr is under Activity>Queue when I hover the mouse on the orange download icon it says: Downloaded - waiting to import and below that it says No files are found that are eligible for import under /data/torrents/(movie name)
I searched the whole volume and couldn’t fund the downloaded file.

yep, wrong port, change it to whatever you chose for your external port for the container. ie in the example i used you would set that to 32800.

just in case you need them you may also want to set some of the custom headers (i dont know if these are actually required or not)

note that when you click on the create button it looks like nothing happens. its added an empty row into that table that is incredibly hard to see but its there and you can just click on both sides of it to add the header name and value

Thank you. I added the Custom Headers.
The external port for the container is also 8989.

To this issue: I changed removed transmission and reinstalled it, this time I changed the folder volume settings to:

Next I went into the /volume1/docker/appdata/transmission/settings.json file and changed the “incomplete-dir”: from /downloads/incomplete to /data/torrents/ now files are being downloaded, but they are not put into the right subfolders (movies, tv, music), with that the hardlinks are not working. Do I need to change the settings for downloaded files to something like /data/torrents/{tv|movies|music}?

transmission is the worst client for automation and does not support categories, but rather can do fake categories with folders

what is the actual folder structure on your nas? your first post says /media but now your saying /data

if you followed the trash guides then the only volume mapped in the containers should be /data = /data (or whatever your base path actually is) (plus your config but thats not important for this)

you would then reconfigure the dockered apps to use /data/.... based paths, not /tv or /downloads

transmission would be set to use /data/downloads/transmission/...
sabnzbd would be set to use /data/downloads/sabnzbd/...
sonarr would have a root path of /data/shows/...
radarr would have a root path of /data/movies/...

because your containers would all be using the same /data/... based paths they can then pass around those paths and they will all line up and be valid.

right now youve got what looks like random paths with no relation to each other, especially for transmission and sonarr - you can fix that with a remote path mapping in sonarr but its much simpler in the long term to fix it at the nas and container level so it will work across all your “media” containers.

I changed the folder structure to Trash Guide’s structure so
/data/media/{movies | music | tv}
/data/torrents/{movies | music | tv}
data/usenet/{movies | music | tv} - > I just created the usenet folder, but I am not using usenet for now.

then /docker/appdata/{bazarr | jacket | plex | radarr | sonarr | tautulli | transmission}

Right now my containers are configured like this:

Transmission-> Settings:


Sonarr-> Settings-> Media Management-> Root Folder:
Screen Shot 2021-06-12 at 15.30.06

Sonarr-> Settings-> Media Management-> Importing:


Radarr-> Settings-> Media Management-> Root Folder:
Screen Shot 2021-06-12 at 15.33.38

Radarr-> Settings-> Media Management-> Importing:


those look good and everything should work “normally” like that.

i would also suggest checking that you have set a category for your indexers in both sonarr and radarr, to sonarr and radarr, just so their jobs, and your own manual downloads, dont end up mixed up when queried.