Sonarr not talking to Plex

After updating to Sonarr v3, I can no longer connect Sonarr to Plex Media Server to force a library update when new content is imported. The connection was working fine with v2, and continues to work fine with Radarr. The only potential fix I could find via google was to make sure Plex isn’t set to require secure connections, which I did. I also tried it with “Use SSL” both disabled and enabled. I checked the logs, relevant part linked below, and the error doesn’t seem to be helpful. I tried purposely entering the wrong IP/port and got the exact same error.

Sonarr error:
IP and port are set correctly:

Relevant section of log file:

System Information
Sonarr Version: ( docker with preview tag)
Operating System: Unraid (Linux)
mono Version:

I’m not sure if that error is exclusively timeout related, but it can happen if no response is received and the request times out. Which could be a firewall blocking it since you see the same with a bad IP/port.

The biggest question is whether that container can hit that address directly, outside of Sonarr, but I’m not sure if you’ll be able to SSH into the container and wget/curl it.

I loaded up the console for the Sonarr docker and ran curl pointed at the plex server and it did return data, so I don’t think the connection is being blocked. It returned “Unauthorized”, but I’m assuming that’s something related to the way curl works (I’m not familiar with it), because Radarr does still communicate with Plex just fine.

Just in case, I did try disabling the firewall on the machine my Plex server lives on (Windows Server 2016), no change.

Could you get some trace logs of the failing test to PMS and post them as well, that’ll give us a bit more information and include any responses Sonarr receives.

Here is the output with log level set to trace:

That should be all I need to do, right? It looks the same to me, but I also have no idea what I’m looking at, so maybe I’m missing something.

Wait, I fixed it! I had Sonarr set up to use a socks5 proxy, and apparently when I upgraded to v3 the “Bypass proxy for local addresses” option stopped working. I disabled the proxy and it connects fine now.

It was still connecting to other dockers on my Unraid server because for some reason I had manually added the local address of my Unraid server to the list of ignored addresses, so that explains that. Presumably I discovered the bypass local addresses option before adding my Plex server’s IP address, and it worked fine that way on v2.

So, possibly a bug? I’m not really sure honestly, I’m just happy it’s working again. I’ll probably just leave the proxy disabled, I can’t see any reason to proxy Sonarr’s connections. I was just learning about usenet at the time and didn’t understand what exactly Sonarr was, I thought Sonarr itself was downloading stuff, so I added my torrent proxy to it just to be safe haha.

1 Like

Nice find and thanks for letting us know.

Sonarr relies on the proxy from .net/mono which takes in an option to bypass for local addresses, that hasn’t changed from v2 -> v3, but could be different in different versions of mono, perhaps the difference being how it detects whether the address is local.

Ah, interesting! I know Docker handles local addresses a bit differently than with native applications, so that would make sense. Well thank you very much for trying to help, I really appreciate it!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.