Sonarr not seeing episodes already on disk


#1

Sonarr version (exact version): 2.0.0.5163
Mono version (if Sonarr is not running on Windows): https://www.linuxserver.io/our-images
OS: https://www.linuxserver.io/our-images
Debug logs:
(Make sure debug logging is enabled in settings and post the full log to hastebin/pastebin/dropbox/google drive or something similar, do not post them directly here. Post in .txt not .doc, .rtf or some other formatted document)
Description of issue: I’m running Sonarr in a Dockerimage on my Synology NAS. It is doing great! I have one issue. I have mounted my Series folder to \tv on the Sonarr image. On my Series folder I have a folder for each Series i.e. “Colony” and then often a Season 1 subfolder and then the files. However if I update the library of rescan the series, Sonarr does not discover them. So I went to “Wanted” and manually imported one series. I point it to the Colony subfolder and then it finds all episodes. I mark them all and import. The default is the “move” and what happens is that Sonarr creates a subfolder with the series folder, which now means I have “Colony/Colony/Season 1”. The same happens when I do a manual scan from the root directory. How do I avoid this dual-series folder creation? What am I doing wrong?


#2

Did you set /tv/Colony as a root folder? You should only set /tv as root folder. Sonarr will then find or create the series folders itself.


#3

/tv is the root folder. In the image it’s mapped to the Series mount point on the Synology NAS, but as far as Sonarr is concerned, it is /tv.


#4

Oh, wait, you’re onto something I think.

In the image indeed /tv is the root folder. The Edit Series however shows /tv/Colony/Colony.

So I changed that to /tv/Colony, but then it says “Path is already configured as a root folder”


#5

So I now removed the series from the series menu, to then add it again with a path of /tv. But then I get an error again “Path is already configured as a root folder”

When I add it with /tv/Colony as a path, it creates the additional Colony directory.

I’ll tinker some more.


#6

Further tinkering with removing and re-adding the series still leaves me with the challenge as stated I’m afraid.


#7

Ok… let’s see. I’m also using sonarr in the linuxserver docker on synology, so our setups are virtually the same…

When you add a series, this is what the path dropdown should look like:

1

If you have multiple paths there (e.g. /tv/Colony, /tv/otherseries…) that’s incorrect.
To fix: remove the series that are in there from sonarr, then click the “add a different path” option in the dropdown above. From the Select Folder dialog, you can use the red x to delete everything and only keep /tv/.

Then you can add the series again and just select /tv/ as the path. That should do it, I think.


#8

That did the trick!
Many, many thanks Thirrian!