Sonarr not moving files over

Sonarr version (exact version):
Mono version (if Sonarr is not running on Windows):
OS: MscOS 10.15
Debug logs:
Description of issue:
I have noticed since the recent updates that Sonarr is telling Vuze to download the videos however they are now not moving to the folders? When I check the files in activity it says it can’t determine if they are samples.

When looking over the logs I get the same reason for all files:
Error|DownloadedEpisodesImportService|Import failed, path does not exist or is not accessible by Sonarr: /Users/kevinpeake/Downloads/Vuze Downloads/tv-sonarr/[Golumpa] Boogiepop and Others - 07 (Boogiepop wa Warawanai) [English Dub] [FuniDub 1080p x264 AAC] [MKV] [10BDCC53]. Ensure the path exists and the user running Sonarr has the correct permissions to access this file/folder

On the iMac I have given Sonarr full disk access to these files, but this is still not working. Any advice?

I am also getting the same error with qbittorrent downloaded files. This seems to happen only when the torrent contains a subfolder with the files in the subfolder.

For some reason, when the download client copies the downloaded files into the completed downloads folder, it is not always creating/copying the subfolder, so the downloaded files end up in the root of the completed downloads folder rather than in the sub folder.

I have noticed that sometimes the release is available on multple indexers, but some indexers show the download with a sub-folder and some show the download without a subfolder. I’m wondering if this is contributing to the problem

This may well be caused by download client / indexers, but it would be good if Sonarr could also check the root of the completed downloads folder for the files if it doesn’t find the sub folder

Alternatively, could we add a failed import to the notification system. the current notifications don’t catch this error

Best to look at the issue on github about macOS (or the existing threads here), mono 6 may also be causing issues.

This sounds like a different issue.

Sonarr uses the path provided by the download client. It doesn’t walk up trying to find a file or folder with an inexact match and that’s not something it’s going to do.

Qbit may have an option to always use a folder (I forget offhand), which may help here.

Please elaborate, which notification specifically doesn’t catch it?

I use an email connector. Options are enabled as follows:
On Grab - Enabled
On Import - Enabled (This specifically says "Be notified when episodes are successfully imported - it doesn’t appear to notify when an import is unsuccessful)
On Upgrade - Enabled
On Rename - Not enabled
On Health Issue - Enabled
Include Health Warnings - Enabled
No Tags configured.

I get emails on grab, successful import and health alerts, but not for a failed import

Gotcha, universal failed import, not for this particular error.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.