Sonarr, Indexers unavailable


#1

Sonarr version (exact version): 2.0.0.5301
Mono version (if Sonarr is not running on Windows): 5.18.0.240
OS: 18.04.2 LTS
Debug logs: https://www.dropbox.com/sh/r5qq09njvg82idf/AAClK4vjWysLqbBVQnQ_jGC7a?dl=0
Description of issue: Sonarr keeps saying that all my indexers that i use via jackett are unavailable.
I use the same indexers via radarr without any problem. For now the only solution that works every time is restarting my computer. Sometimes, changing my hostname in the URL field from “127.0.0.1” to “localhost” and back, seems to work to but not always. The default URL with the IP adress of the computer works only for a day or 2 and then never again until i restart. I used radarr and Sonarr on a windows 10 pc for some time without this problem and cant figure out why this is happening now. This is my first time using any kind of Linux and the first and for now only problem i cant figure out, so please if i have to do anything or post anything else, please say what and how


#2

Do these logs show when Sonarr disabled the indexer or only subsequent failures? The latter is irrelevant, so we’ll definitely need to source of the issue.

Are you using the combined Jackett indexer in Sonarr (/all is similar) or is each entered into Sonarr? With the combined one a failure in either could cause Sonarr to disable it.


#3

These logs are only of the subsequent failures. i will do a reboot and wait untill it happens again and then post the logs.

Also i am not using a combined jackett indexer, i did try that but gives the same error and also would like to keep it separated so i can choose wich indexer to download from when i search manually


#4

Here is the link with the new logs: https://www.dropbox.com/sh/r5qq09njvg82idf/AAClK4vjWysLqbBVQnQ_jGC7a?dl=0

These are all the logs since i rebooted about 30 hours ago. Last time i checked was about 8 hours ago and everything was working fine then, so it must have happened in the last 8 hours.


#5

According to the logs, around 19-2-27 16:11:13.2 almost every search fails due to timing out after 100 seconds and then they’re disabled.

Not sure if Jackett has anything in it’s logs indicating why it took that long to respond.


#6

i will reboot again and let Jackett log too and post it here


#7

What version of Jacket are you running? I had this problem for a while also. Jacket would just fail everything. I ended up taking mejortorrents (which wasn’t even in Sonarr) out of Jacket and few others that I noticed causing problems in the Jacket logs. I don’t remember now if that fixed the problem or if it was fixed when I upgraded to the prerelease version (which of course comes with its own issues. (Right now I am fighting with what I believe to be a mono dns timeout issue-more an irritation than a real issue)).


#8

Jackett version is 0.10.852.0, but would’nt it be weird if it was a Jackett problem since i have no problems in Radarr with almost all the same indexers, only difference is the YTS indexer wich i use in Radarr but not in Sonarr


#9

When i was having this issue, Sonarr was the only system with the issue, but restarting Jackett would fix the problem for a day or 2. also, Jackett’s instance of mono was eating a lot of the memory. If I left it long enough after Sonarr started failing, Radar would eventual fail as well.


#10

I haven’t tried restarting Jackett before, i will try that next time


#11

i have rebooted again, this time with logs for jackett running as well wich can be found here together with the sonarr logs: https://www.dropbox.com/sh/yv12z5owe5m3djw/AAD-7bRmui7Ary5pTAsRErOSa?dl=0

i tried restarting jackett but this didn’t seem to do anything, Radarr indexers are stil running, Sonarr indexers still aren’t, and if i test any of the indexers in Jackett, they too are still fine


#12

dumb question, but did you test the indexers from Sonarr after you restarted jackett?


#13

yes, also didn’t work, and no dumb question


#14

Okay, unfortunately, you need to do this one more time. The Jackett logs stop before the Sonarr logs make it to the problem (I think you just left out log.txt) and Sonnar is not running with mono --debug. Please do the following:

In Sonarr:

  1. Disable EZTV (Jackett’s process for parsing it is broken (or at least inconsistent) ATM and causing us to wade through an error for every result).
  2. Change logging to debug
  3. Make sure to save

In Jacket:

  1. Remove EZTV (you can put it back later)
  2. Make sure both of the following are checked:
    a. Disable Auto Update (so we don’t get an update in the middle again)
    b. Enhanced Logging
  3. Make sure to save

From a command line/terminal (change service names and paths as necessary–you already know where the logs are)(I am zipping the logs just in case you need to refer back to them later).

sudo systemctl stop sonarr jackett
cd /home/jackettuser/.config/Jackett
sudo tar czvf oldJackettLogs.tgz *.txt
sudo rm log*
cd /home/sonarruser/.config/NzbDrone/logs
sudo tar czvf oldSonarrLogs.tgz *.txt

I use vim, but you can, of course use whatever you like

sudo vim /etc/systemd/system/sonarr.service

or whatever you named your service.
Change ExecStart=/usr/bin/mono /opt/sonarr/Sonarr.exe -nobrowser to ExecStart=/usr/bin/mono --debug /opt/sonarr/Sonarr.exe -nobrowser and save the file.
(for vim, place the cursor between mono and /opt, press i, type --debug (make sure to leave spaces around it). press the following, in sequence : esc : w q enter

Then:

sudo systemctl daemon-reload
sudo systemctl start sonarr jackett

Once you notice it having the problem again:

sudo systemctl stop sonarr jackett
mkdir ~/jacketlogs ~/sonarrlogs
cd /home/jackettuser/.config/Jackett
sudo cp *.txt /home/youruser/jackettlogs/
cd /home/sonarruser/.config/NzbDrone/logs
sudo cp *.txt home/youruser/sonarrlogs/
cd /home/youruser
sudo chown -R youruser:yourgroup jacketlogs sonarrlogs
sudo systemctl start sonarr jackett

At this point you can re-add EZTV, turn Jackett automatic updating back on, and put the logs back to info/not expanded (you can leave mono debugging on). Then post the logs we saved in your home directory in a new dropbox folder.


#15

i tried your steps but got stuck at stopping Sonarr with this error message: Failed to stop sonarr.service: Unit sonarr.service not loaded. so it seemes Sonarr isn’t running as a service but i’m not realy sure. i used this guide to install Sonarr: https://www.htpcguides.com/install-nzbdrone-ubuntu/

EDIT: i used the github guide for installing and used the guide in the link above for starting automatically

no problems with stopping Jackett however.

didn’t go any further with the steps after that

you’re right, i didn’t post the log.txt, thought they were irrelevant for lacking a date, sorry :neutral_face: and i will post them next time. debug logging for Sonarr and extended logging for jackett are already on btw.


#16

Got sidetracked on another project. Okay:

Ahh. I saw that you were on 18.4.2 LTS and assumed you were using systemd. Try using nzbdrone instead of sonarr. if that doesn’t work, try sudo service nzbdrone stop

This is the autostart directions from the wiki for Ubuntu newer than 16.04:

No worries: the one without a date is just the one it is currently writing.

Yep, was just for completeness. Now I can refer people to this thread rather than re write all of it :smile: Main concern was getting the mono debugging turned on and keeping the EZTV issue and Jackett updates from getting in the way.


#17

I think i may have found the source of the problem. I was running al programs i use on 1 pc, (sonarr, radarr, plex, deluge, jackett) wich was fine except for the occasional problem with plex and my vpn. Because of that i was looking for the option to have deluge run on a seperate system so i wouldn’t have my pms behind a vpn. I did just that so my deluge and vpn aren’t on the same machine as my plex (and sonarr/radarr/jackett) and i haven’t had the problem in more than a week, when normally the problem would always occur in less than 2 days. I think for now, problem solved