Sonarr Hardlink not Working

Sonarr version (exact version): 3.0.8.1507
Mono version (if Sonarr is not running on Windows): 6.8.0.105
OS: Debian 11.4.0
Debug logs: https://www.toptal.com/developers/hastebin/enipegotuy.yaml

I cannot get hardlinking to work with Sonarr (and Radarr for that matter). I followed the file system and settings recommended in the guide at https://trash-guides.info/. I have also tried to make sure that sonarr has the appropriate permissions to read/write files in /data/torrents/tv and /data/media/tv, however in the trace logs (if I am reading these correctly) Sonarr does not seem to have permission. I am not sure what else to try (I am sort of new to linux). Any help is appreciated.

I should add that the user sonarr and the main user are in the group media, and I have granted the group media rwx permissions to the folder /data and all subsequent folders.

If sonarr does not have permissions then the error is not wrong

ls -lha of all the paths involved

systemctl cat sonarr

https://www.toptal.com/developers/hastebin/hinuhoqiwu.yaml

The output from systemctl cat sonarr says group=sonarr, but I have verified with “groups sonarr” that the user sonarr is a member of the group media. Could this be the issue?

Being in a group doesn’t matter. So sonarr is not running as the group media, that’s the problem.

I knew I must have been missing something obvious. Thanks!

Sorry I jumped the gun there. I changed the group sonarr runs as to media with “dpkg-reconfigure sonarr”, and the log files still show that the hardlink was not permitted.

https://www.toptal.com/developers/hastebin/epihofomuj.apache

So I think I see the problem now. New downloads into the torrents/tv folder have -rw-r–r-- permissions, is there a way to set new downloads to give write permissions to the group as well? I’ve tried searching for this but haven’t figured it out.

That’s based on the settings in your download client or UMASK it runs as
002 for 664/775 for RW for group