Sonarr Connect, Chrome extension


#21

Not quite, it does update even if the browser isn’t restarted, but there is a huge delay and I have no idea what causes it to update.

All-in-all, really nice looking extension so-far, good job! :smile:


#22

@M0UL @wewereus We have noticed that the badge update is not working well.
In the upcoming release it will update on interval that can be set via the config page.
If all tests go well the update will be released today.


#23

@tomreinartz @killer8

images don’t load on the series overview with basic auth enabled…

EDIT: After updating to 1.3 series tab doesn’t load at all, even with basic auth disabled


#24

Hi, Update 1.3 should fix this basic auth problem with images(I had the same on my setup).

I’ve double checked 1.3 and can’t reproduct your problems with the series tab. Do other tabs work fine? Do you get any errors when you right click in the series tab in the extension and press “inspect element” (In the window which opens you should see red errors at the bottom if available). Incase you have any errors please share them so we can have a look and fix the issue.


#25

Both other tabs are behaving…
EDIT: Removed pix


#26

Hi there, it seems like there is a problem getting the right data from sonarr.
Could you let us know what version of sonarr you are using? We will try to reproduce this error and fox it as soon as we can.


#27

the series tab is empty for me too.
i am running version 2794 (develop) and sonarr connect 1.3.0


#28

We’ve released a new version:

1.4.0
Season 0 is called Specials now
Options page will open automatically when extension is not configured
Check if image url is set


#29

@killer8 1.4 fixed it for me! :smiley:


#30

works in 1.4


#31

@killer8 maybe hide the badge when it is equal to 0


#32

I have my sonarr installation behind a modproxy proxypass redirect and the base url set to “sonarr”, so that I have all my web based applications available on port 80.

So, to get to my sonarr website I would goto “http://my.websiteaddress.com/sonarr/”.

Unfortunately, Sonarr Connect will not accept this location for whatever reason. When on the local network, it is accessible via port 8989.


#33

HI Wolfienuke,

We think that your Sonarr Api is not available if you use your mod proxy,
Could you check if
"http://my.websiteaddress.com/sonarr/api/system/status?apiKey={your api key}"

Is accessible via the browser?
Thanks


#34

@delphi_actual We have created an issue for this and add this as an option in a future version https://github.com/C-Vaes--T-Reinartz/Sonarr-Connect/issues/5

@Wolfienuke Same setup for me and it’s working, so like Tom said maybe the api is not available.


#35

API is available behind modproxy proxypass…

{
“version”: “2.0.0.2804”,
“buildTime”: “2015-02-04T20:19:58Z”,
“isDebug”: false,
“isProduction”: true,
“isAdmin”: false,
“isUserInteractive”: false,
“startupPath”: “/volume1/@appstore/nzbdrone/share/NzbDrone”,
“appData”: “/usr/local/nzbdrone/var/.config/NzbDrone”,
“osVersion”: “3.2.40.0”,
“isMonoRuntime”: true,
“isMono”: true,
“isLinux”: true,
“isOsx”: false,
“isWindows”: false,
“branch”: “master”,
“authentication”: false,
“sqliteVersion”: “3.8.7.3”,
“urlBase”: “/sonarr”,
“runtimeVersion”: “3.10.0 (tarball Fri Dec 26 11:31:45 MST 2014)”
}


#36

Oke, that means atleast your reverse proxy is configured correctly. Are you using the complete address including sonarr? My own url is configured like: https://server.home.com/sonarr/ that works for me.

Incase that’s not the problem can you tell me what error you see when you click “inspect element” in the sonarr configuration screen and press “test connection”. I’m wondering what goes wrong exactly.


#37

I got it now, it’s a 401 authorization issue. Either I need to disable authentication, or wait for username/password field to be added to the chrome extension.


#38

You’re using the username and password from inside sonarr I guess? I’m using the same, beside that I think there is no username password Auth when the api key is used. So I expect your api key to be wrong this should also return 401. Can you double check that?


#39

No, I was using authentication using modproxy. A quick edit of the configuration solved the issue.

Thanks for the help, I never used inspect element to try to diagnose an issue like that. It will help me considerably in the future.

Sorry to trouble you with an issue that was caused by my server configuration, and not your extension.


#40

You’re welcome, Incase you still want the auth on apache instead of sonarr you can try to exclude /api from the authentication.