Sonarr cant fetch files from Sabnzbd in docker

Sonarr version (exact version): 2.0.0.5322
Mono version (if Sonarr is not running on Windows): 5.18.0.240
OS: DSM 6.2.2-24922
Debug logs:
Description of issue:
I am so close on my synology ds1019+ i started running docker and i finally got it all to work. but when sabnzbd is done downloading the file Sonarr can not get it. I know the mapping is not right. but I dont know how to fix it. also I cant even see the file when its been downloaded. I am very new to docker. I would love some help please. here is 2 pic that i have taken. hopefully someone can help. thanks

This is probably a good read to get you started:

https://www.reddit.com/r/usenet/wiki/docker

It comes path mappings for docker, basically you need to make sure SAB is saving files to a location that is physically on disk (which Sonarr running on the syno directly or in docker will be able to access). Ideally the path is the same for both SAB and Sonarr and on the same volume (both virtual and physical) so imports are simple moves instead of having to copy to another volume. If thta’s not possible you can use a remote path mapping in Sonarr to remap the remote path from the download client to something it can access locally.

I have read threw everything. tried what I believe to remap it. but still nothing. is it wierd i can not see the finished download? When I was running sonar sabnzbd on their own and not in docker I could see the incomplete/ complete downloads. ( but I had problems with the files disapearing on me in plex and no one could give me a answer why). So I was hoping to figure out Docker. I am ready to pull out my hair

They’ll be wherever /config is mapped to on disk in your docker config, if you didn’t make /config to a physical location on disk that’s your problem.

thought i remapped it correctly but still not working

sabnzbd3 sonar%202

/Config is not the same as /config so SAB is saving files within the container only.

You’ll also need to tell SAB to save them in /complete (the path mounted in the container), not the path on the physical system.

ok im and starting to understand. since the files are being saved inside the container thats why I can’t see them on the physical system. now how can I tell SAB to save them to the /complete (the path mounted in the container)? maybe I need to change the name of the physical system files names cause I am not seeing it?

In the settings screen shot you posted, Completed Download Folder.

Beyond that you need to fix the path to config, you didn’t specify it correctly for SAB’s docker container and the config will be stored inside the container only, which means you’ll lose all your settings when you rebuild the container.

hey just wanted to say I figured it out. It took me a bit to understand but I got it. Thanks for your help and patients

1 Like

Hi,

I have had exactly the same problem, I finally resolved it by removing the download folder created for Sabnz… and recreating the folder again, but this time via the creation of the container, this seemed to resolve the problem as the container could now access the host folder. Thereafter ensured the permissions on the folder where appropriate. This fixed the issue for sonnar/sab, haven’t checked to see what is has done to radarr/sab as they use the same folder structure.