Sonarr can no longer connect to download station on synology

Sonarr Version. 2.0.0.5338
Mono Version: 5.8.0.108-11
Synology DS118 DSM 6.2.2-24922 Update 4

I’ve had Sonarr running flawlessly for many, many months on my DS118. I often load up the landing page just to check what shows are coming up, deal with any failed downloads or search for shows that might have not been grabbed - nothing major really.

Today, I go to the main page to see a red error notification and i find out that it can’t connect to the download station. So I go to the settings page assuming i have to re-verify the download client by re-testing and saving it and I get these messages …

Failed to get the list of torrents: Failed to login. Reason: No such account or incorrect password

Unknown exception: Failed to login. Reason: No such account or incorrect password

This is, of course, nonsense. My password is the same as it always has been and the administrator user that i’ve been using is also the same.

I do not have 2-step verification enabled either.

The strange thing is though, I downloaded and installed the “Medusa” package and when I tried to connect to the Download Station, I also got an error saying “Unable to get DownloadStation Authentication, check your config!”.

I don’t know what i’m supposed to check because I literally have changed nothing in the past months.

I tried uninstalling and re-installing download station and that made no difference so i’d really appreciate any help.

DSM 6.2.2. update 4 is just under 3 months old so you’ve made at least one recent change. although if you have it set for auto OS upgrades you may not have noticed.

its possible that has changed something behind the scenes, although im not sure what. perhaps go through and double check you can manually access downloadstation using the credentials you entered in sonarr?

if you can get it to work manually then it should work automatically

And just like that, i’ve fixed it :slight_smile:

I edited the administrator user that I created, which is the one I use with sonarr, and I noticed that the permissions for the download directory I use were unchecked, so I allowed read and write permissions for that.

Had a look in the applications tab and sonarr was also unchecked so i checked that, saved and re-added the download station client and it worked !. Crisis over … hah :smile: