Some torrents get suck in pending after I set the torrent delay

Sonarr version (exact version):
OS: Windows 10
Debug logs: silmarine torrent delay pending · GitHub
Description of issue:
A while back I set the torrent delay to 360 minutes in order to prevent having to redownload when a better quality is found shortly after release time. Before that I kept having the situation where it would download the best torrent found but then soon after a better version would be uploaded, which caused a redownload. Recently I’ve trouble with some episodes being stuck in pending status for days and the only way to get them out is to cancel the download and manually search the episode again. Looking through the logs (see above) that it says there’s a HTTP Error 500 “Invalid torrent file specified” for the file I had left in pending for troubleshooting. The exact torrent in the logs is “Handmade.Britains.Best.Woodworker.S03E05.1080p.WEB.H264-SKYFiRE” and when I search for that in my trackers it is not found, so I think that this error might be caused when the torrent it previously found has been removed. Or am I misunderstanding how torrent delay works?

I also use torrent delay but in a slightly different way. In my case, I use both Usenet and torrent but since Usenet has no sharing requirements, I wait one hour once an eligible torrent is found to see if there is a NZB posted for the same episode. If there is no NZB posted it triggers the torrent download. In my case, I have never had a torrent get stuck with the indexers that I am using. If you are using a torrent indexer that only supports RSS that could be the problem as the torrent would very likely been removed from the RSS feed after a 6-hour delay or if the indexers are somehow tagging the torrent as being on the RSS aging out in 6-hours could still be a problem.

Good clue, thanks. I looked at the ones I remember being stuck recently and they all came from the same tracker, so maybe that one’s RSS has the issue you described. The next time I have one get stuck I will check if it’s also that tracker and if so I might just remove it. It’s one of my less used ones anyways.

Did you turn on the “Bypass if Highest Quality”? This will tell Sonarr to ignore the delay if your highest quality in the quality profile used by the series is available (no use waiting 6 hours if the highest quality you want is 1080p and a 1080p version was posted).

Yes, I do have that turned on and it seems to work well.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.