[SOLVED] Running Sonarr in Synology Virtual DSM - but DS won't connect


#1

Bit of an unusual one here, probably, but hoping that somebody might have a bright idea.

I have Sonarr running via docker on my Syno NAS. However, because the VPN setup for Synology applies to the whole device (or nothing) - there’s no service-based routing - I’ve been searching around and the generally accepted solution appears to be to run a VirtualDSM instance with a VPN configured, and run Sonarr/Radarr/DownloadStation on that. That way, the downloads (and Sonarr/Radarr) go through the VPN, but everything else running on the ‘real’ NAS goes straight out to the WAN. This means I can download from iPlayer without the VPN interfering, for example.

I’ve got it all set up - DS is working, Sonarr and Docker running on the VDSM, so it’s 99% there. I can contact DS via its API from a third-party process on the VDSM. However, when I try and connect Sonarr to the DS as a download client, it fails - and I’m not sure why. Same for Radarr. There’s probably some weird networking thing with Docker/VDSM/Sonarr etc, but not really sure how to figure it out or debug.

Has anyone done a setup like this? It’s mentioned in a few places on Plex/Sonarr/Synology forums, so probably reasonably common. If so, did you have to do anything magic to make this work?

Any suggestions gratefully accepted. :slight_smile:


#2

Just in case anyone is doing a similar setup and wants the solution, I solved this thanks to an obscure post on reddit. Basically, Sonarr needs to be given the IP of the Docker gateway (usually something like 175.10.x.x) and not the IP of the containing virtual DSM. Then it all springs into life! :slight_smile: