[solved] Rarbg indexer suddenly unreliable


#1

Sonarr version (exact version): 2.0.0.5085
Mono version (if Sonarr is not running on Windows): 5.4.1.6
OS: Ubuntu 16.04
Debug logs:https://pastebin.com/BU24nc3J
(Make sure debug logging is enabled in settings and post the full log to hastebin/pastebin/dropbox/google drive or something similar, do not post them directly here)
Description of issue: Try to update captcha or test existing indexer

So this indexer has been stable for these many months I’ve been using Sonarr. Until very recently - about two days ago at the most.

I have tried taking some of the URLs in the log that fail and putting them in a browser and they work ok (for example, This link gives me this result)

Is there a better alternative? I can’t seem to get any others to work at all, so that’s why I went with Rarbg.

Also… Why is Rarbg letting me down all of a sudden?

BTW, no recent upgrades or system changes; things just chug along, usually. I upgraded not too long ago - about a month or so – and everything worked just fine after that until Monday’s show failed to d/l due to this indexer problem.


#2

Same here, not sure what’s going on, I can’t even load a new one.


#3

<title>torrentapi.org | 522: Connection timed out</title>

Cloudflare was unable to connect to RARBG’s backend server in a reasonable amount of time, so the connection timed out. This isn’t anything on Sonarr’s end.

I believe the captcha will no long work due to changes on Cloudflare’s end last year (early-mid).


#4

I appreciate that, markus101. What’s a good alternative if rarbg is not going to work any longer? I can’t seem to find anything else that works unless you have an “invite” … and who’s gonna invite me? :confused:


#5

I think you’re jumping the gun, it seems to be working here right now, the issue could be resolved already.

You’d need to either get into a private tracker or you could try a free on through Jackett if you want something else that supports searching (Torrent RSS should work if you add one to Sonarr).


#6

Agreed; it’s working for me, now as well.

Well, that was scary.

On the plus side, it did kick me to get an account on drunkenslug… Maybe they can be the backup.


#7

Still offline for me, same thing a 522 error.


#8

Maybe spoke too soon, yeah, it tests now I guess it was just a temporary system issue.


#9

it seems i have the same issue but it’s not solved yet and it seems at the same time my logs are not working.
tried to restart and reinstall and still having the same issue.


#11

Still doesn’t work for me.


#12

the thing is that sometimes it works sometimes it doesn’t. It is very intermittent…

And that to me is no good.

Does anyone know of any good alternative that we can use on Sonarr?


#13

Use Jackett, it’ll let you use public trackers like worldwidetorrents, pirate bay, l337x etc via the Jackett api. Like a proxy for searches.


#14

We had this problem a year ago or 18 months something like that, anyway it lasted about a month or 2 before it was fully fixed, i had to resort to setting up jackett back then as there was no other public sites that would work with Sonarr. If you set up jackett you will still be able to contiue using rarbg even though their api site is down.


#15

Having had the same problem last few days I decided to install Jackett. I setup the same Rarbg site in Jackett and it does seems to go through no problems albeit seems a little slower but atleast I have had no issues since then.


#16

Thanks to all who responded. I’m going to give Jackett a try.


#17

If you have the normal Rarbg Indexer still active then it will seem slower with jackett as it is still trying to do searches with the rarbg indexer and it has to wait for a timeout. Just disable Rarbg for the time being until you know its completely fixed.


#18

Jackett set up - about 5 indexers set up in Jackett. Quite the system. Interesting that rarbg works here as NukuVarjo pointed out. Thanks again, everyone.


#19

Rarbg is now working


#20

just this week rarbg doesnt work doesnt matter where i click on the page nothing but popups that get closed right away from adblockers i have installed on my browser only way i can get to any page is to refresh the page and fast as i can click on the page i want this is retarded and will only keep people away from this broke as site plz fix this problem as i use this site all the dam time this is a total pissoff


#21

I think there is a major issue with your keyboard. All punctuation marks, as well as your shift key seem to be broken.

Also: sonarr doesn’t operate or have anything to do with the rarbg website. It only uses rarbg’s rss feed. You may want to redirect your internet rage elsewhere.

PS: I have nothing to do with sonarr either. Just an amused user.


Somewhat back on topic: the real reason that Jackett works is because it screen-scrapes rarbg’s website, to the best of my knowledge. Most websites won’t like you for it, and may eventually ban you/the software you’re using/both for doing it.
Since rarbg’s rss feed has a tendency to go down every once in a while, and that is what sonarr uses, you may see this behavior where rarbg doesn’t work in sonarr but it does work through jackett…