Solved: Killed Sonarr with jail update to Truenas 13.0

**Sonarr version (exact version) **
Mono version (if Sonarr is not running on Windows): 6.8.x
OS: Truenas/Freebsd
Debug logs:
Description of issue:
Unable to start after jail OS upgrade.
Running in a jail, and Sonarr has been doing fine for years. Upgrade to 13.0 broke almost all jails and I’ve gotten about half back.
Sonarr has even been reinstalled with same effect. “Service sonarr start” produces no error or startup two 15 hours of reading has not produced any solution. Jail is running and reboots, restarts have no effect.
Would greatly appreciate some help.

You didn’t mention what you tried, so this might be repeat, but as with many issues, seems like this could be related to mono


There are other bugs listed as well, plus posts here and there. Common theme seems to be you need to roll back the mono version.

You may be right. I remember the debacle going from Sonarr 2-3 and mono 5.10.
I tried removing the installed mono but it wanted to take Sonarr with it so that took some time to force the issue. However, I’m not sure how to change the repository and pull from elsewhere (researching now)
I still have the .txg file (early 6.8x) that it was running under before but haven’t found the command parameters to place it and unpack properly.
I’ll work in that direction. Thanks for the bug report and pointer.

Kudos to Fanboy!!!
Mono was the problem.
Uninstallation wants to take Sonarr with it.
Lock the Sonarr PKG
Remove the current mono by using --force
Copy the mono .txg archive to /tmp
pkg install /tmp/mono-

All of the above are done with pkg except of course putting the file in /tmp was what I was running before and is running again. I have no idea where the mono versions broke it and I see they are up to 6.12.x

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.