[Solved] After failed update Sonarr wont launch

Sonarr version (exact version): 3.0.3.711
Mono version (if Sonarr is not running on Windows): 5.18.0.240 ( 6.8.0.105 now)
OS: Debian 10
Debug logs: https://privatebin.net/?7cc9574fb1f74669#3YeWVpxJxSfR9gm4spEfqcQz91mQTuURxkHB3bWxEnoM
Description of issue: Updating Sonarr failed and now I get this error when trying to launch Sonarr.

EDIT: Tried to manually to latest version and updating mono but still getting errors

It looks like there are some DLLs from v2 that should have been replaced during the upgrade, since we use Nancy 2.0, not 1.4.

At this point I’d uninstall Sonarr, make sure the bin folder for it is empty and reinstall.

[Info] Bootstrap: Starting Sonarr - /opt/NzbDrone/Sonarr.exe - Version 3.0.3.731

This is the v2 bin directory, but you’re running v3.

1 Like

Back in the day I just used the old directory and it worked.

I removed everything inside and put the files of v3 in there again. Now I can access sonarr but it is showing me just a white page. Same behaviour in a new environment. I also deleted the Sonarr directory in .config:
https://privatebin.net/?5290c5a8e5ec7110#D1JAPcX4QfaUKpGE8JBGTvrCdanomwqSnPFMsmMtxnZD

EDIT: Nvm. It seems that V3 can’t start with an empty config directory. All fixed. Thanks!