[SOLVED] "Access to the path is denied" but permissions appear open


#1

Sonarr version (exact version): 2.0.0.5322 (installed from apt)
Mono version (if Sonarr is not running on Windows): 5.18.1.0 (installed from apt)
OS: Debian Stretch 9.8
Debug logs: https://pastebin.com/7ezjKbHT
Description of issue:

Long story short, my OS disk died and although I had a backup of various databases, I didn’t have a complete OS backup. Shame, I know. Now I’m setting everything back up, but it’s been years since I did the initial setup so I don’t remember the exact processes I went through.

I’m currently having an error with Sonarr being able to import files. The basic error it throws is Couldn't import episode /mnt/canaryssd/NzbDownloads/complete/<file>.mkv: Access to the path is denied.

I’ve done research on the error but haven’t found anything useful. Here’s some info on my setup:

  1. Source and destination are two different drives
    • Source: /mnt/canaryssd
    • Dest: /mnt/md0
  2. Sonarr runs under sonarr:sonarr
  3. Each mount and all dirs/files is set to 777, and files owned by nobody:canary (sonarr belongs to the canary group)
  4. I’ve tried various ownership, including sonarr:sonarr. Nothing has changed the outcome
  5. I can successfully copy and move files as sonarr’s user using su - sonarr
  6. I can successfully add both the source and destination under “Import Existing Series on Disk”
  7. I have restarted sonarr (and my server) repeatedly throughout this process
  8. Transmission downloads to /mnt/canaryssd/Downloads and SAB downloads to /mnt/canaryssd/Downloads - neither can import

Update: Importing works as expected with Radarr.

As far as drives go, this is the same setup as before my OS crashed - files download onto my SSD and then when complete, get moved to the raid array.

I’m not sure what else to debug. Any assistance is greatly appreciated. Please let me know if you need any additional info.


#2

im having the same issue only using nzbget.

the solution i found is that restarting sonarr fixes it


#3

Restarting doesn’t make a difference for me, unfortunately.


#4

I solved my issue. As the error suggested, it was a permissions issue. SAB and Transmission are inside of a linux container, and the permissions in the container weren’t set up correctly. I had to configure permissions in SAB and umask in Transmission.