Slug is in Use, correct on TVDB

Hello, I’m trying to add “The Planets (2019)”, but already have The Planets (1998) added. When I try to add the new series, it says the path and slug are already in use. I created the folder and tried to import, and it says the slug is already in use. However, when I go to TheTVDB, I see that the slug should be the-planets-2019, but sonarr isn’t picking up the correct slug. When I click “out” in the interface, it brings me to the wrong series in TheTVDB, even though it shows correctly in the search output preview.

The slug is generated on skyhook, TheTVDB’s slug is not currently used. If multiple series have the exact same name, The Planets for both 2019 and 1998 then that’ll cause multiple issues, beyond this particular issue.

Does that mean there’s no resolution?

Just checking in here if there’s a way that I (or someone) can fix this in skyhook?

I’m still hoping to find a way to fix this. Is there anything that I am able to do or contribute to resolve this?

TheTVDB’s rules indicate that series with the same name in later years should have the year appended to the title, that will need to be changed on TheTVDB (if the series is unlocked anyone can do it).

As noted, the year is appended in TheTVDB. It is the-planets-2019 on TheTVDB, and the original is just the-planets.

Please see: The Planets (2019) -

What TheTVDB has for the slug doesn’t matter the slug Sonarr uses is based purely on the title, but since that has been fixed on TheTVDB already there should be no issue adding both.

Ok, I see what happened. For some reason when I imported the 1999 version it was actually the 2019 version and then errored when I tried to import the 2019 version.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.