Skyhook timeout when adding new series

**Sonarr version **: 3.0.6.1265
**Mono version **:5.20.1.34
OS: unRAID v6.9.2
Debug logs: https://hastebin.com/ukukevivoh.yaml
Description of issue:
Searching for new series always hangs for ~60 secs or so, then responds “Unable to connect to Skyhook”

I’ve tried binhex and Linuxserver.io’s images, both produce the same result. From the container’s console, I can curl https://skyhook.sonarr.tv/v1/tvdb/search/en/?term=dragon and get a result back within a few seconds, so the container networking appears to be fine.

I am also unable to connect to any Usenet indexers, basically it appears Sonarr can’t talk to anything outside my local network.

This problem just sorta appeared one day a couple weeks ago, I can’t explain why. I have Radarr, Overseer, Jackett and other containers running on this unRAID server and they all work great.

This is a local networking or routing issue and not a sonarr issue.

Please explain. This is a brand new fresh Sonarr config. From within the container, I can access skyhook.sonarr.tv. Sonarr, however, cannot.

Bump. Why is Sonarr unable to connect to the Internet when I can connect fine through the console?